Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My work desktop PC has just been refreshed and now I'm using Windows 7 64bit.

Seeing as my employer uses Ubuntu development servers with svn 1.5, I've installed PuTTY, Pageant and TortoiseSVN 1.5.10-x64. I've set up pageant to use my ssh key and it and PuTTY seem to be working fine.

However, if I try to do any operation on the working copy, I get a TortoisePlink dialog, asking me "login as:".

It will work if I enter my ssh username for the server the svn repository is located on, but often it will require me to enter the username multiple times (I just tested "show log" and I had to enter my username 4 times). However, it doesn't ask me for my password, so it must be getting my ssh key from pageant.

When I used Windows XP, after setting up pageant correctly, TortoiseSVN never prompted me for anything.

Why is it asking for a username when it didn't before? Isn't that information stored in the working copy? And how can I specify the username I want it to use for a particular working copy so that I wont have to enter it again?

Note Because our servers have svn1.5 and svn automatically upgrades working copies to the current format and working copy formats are not backwards-compatible, I need to use TortoiseSVN 1.5 for a hassle-free life. So any solution which doesn't involve upgrading my svn or tortoisesvn is appreciated.

share|improve this question
add comment

2 Answers

up vote 7 down vote accepted

This is a known issue. Tortoise 64 bit is pointing their finger at PuTTy 32 bit :

share|improve this answer
    
Thanks for that. I'd give you an upvote, but apparently, I don't have enough reputation. –  Paddy O'Loughlin Jan 20 '12 at 0:04
add comment

By default, PuTTY will always ask you for username, unless it is already provided in the hostname or in the session settings.

  • a) Modify the hostname (in your SVN address) to read user@host instead of just host.

  • b) Open PuTTY, go to Configuration → Connection → Data, enter your name as "Auto-login username" (or pick the "Use system username" option). Go back to Session, select "Default session" from list, click Save.

The same applies to all programs in PuTTY package (PuTTY itself, plink, pscp, psftp).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.