Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a pretty decent DSL connection that usually gave me about 105KB/second download speed over wifi. The "official" download speed was 1.5 megabits so I should have been getting a bit more, but that's not my question.

I recently switched to Mint from Ubuntu. Now my download speed is significantly slower, to the tune of 45 KB/second. Since the connection runs at normal speed when I connect via an ethernet cable, my guess is that mint doesn't give enough power to the wifi card. Is there any way I can fix that?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

There was a similar question about wireless speed dropping in Ubuntu. The solutions included turning down Tx power and moving the laptop further from the AP. IPv6 is also a possibility, but I would try Tx power and physical distance first.

Since you noticed a change from Ubuntu to Mint(which is Ubuntu derived), I would think that you just "noticed" it. An alternate possibility is that Mint is using an older wireless driver. The latter is doubtful, but worth checking.

share|improve this answer
    
I'll check the driver, though I doubt it since I was using Ubuntu 10.04 but upgraded to the latest version of Mint –  Yitzchak Sep 20 '11 at 14:48
    
If it's not the driver, Mint might have disabled N support for the driver...check /etc/modwhatever for differences. –  hbdgaf Sep 20 '11 at 14:50
    
Nope, but thanks for the ideas. –  Yitzchak Sep 20 '11 at 23:39
    
I moved the router away from the large metal Powermac tower and large metal desk it was resting on top of and that solved my problem, though it doesn't explain why it was an issue to begin with. –  Yitzchak Sep 21 '11 at 0:19
add comment

This could be related to IPv6 turned on, on the wireless interface according to user Aaron on a how to disable IPv6 post in linux mint.

Here is the post, it includes instructions of how to disable IPv6.

Hope this works.

share|improve this answer
    
That post mentions that the answers won't work in newer kernels where ipv6 is built in. –  Yitzchak Sep 20 '11 at 14:40
    
ok, checking for another solution. –  bbatman Sep 20 '11 at 14:48
    
if it is ipv6 and it's a builtin you might be able to disable it rebuilding your kernel...just a thought. –  hbdgaf Sep 20 '11 at 15:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.