Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My hard drive has a fresh install of Snow Leopard. I checked the connections with Network Utility, and everything looked fine.

I changed my hosts file with the one from here:

http://someonewhocares.org/hosts/

After I flushed the cache, I ran Network Utility again, and it showed w9.hitbox.com as LISTENING. If I connect to the internet, it shows as CONNECTION ESTABLISHED.

Why is this, and do I need to change something to make the hosts file work correctly?

EDIT: The beginning of the hosts file:

127.0.0.1 localhost

127.0.0.1 localhost.localdomain

255.255.255.255 broadcasthost

::1 localhost

127.0.0.1 local

and further down: 127.0.0.1 w9.hitbox.com (along with a bunch of other blocked sites)

share|improve this question

migrated from security.stackexchange.com Sep 19 '11 at 22:00

This question came from our site for Information security professionals.

    
Hi @Javy, welcome to Information Security! But is this really a security question? –  AviD Sep 19 '11 at 21:34

2 Answers 2

up vote 2 down vote accepted

EDIT Based on your update, it is more clear that your machine is referring to itself as w9.hitbox.com. Take that address out of your hosts file, flush your cache, and run your network utility again. You have a service listening on the IPP port, and that's pretty common for OS X.

It's likely that the ordering of entries in your hosts file contributed to this. It may be the best practice to put the localhost entry at the start and end of the file if you have multiple lines referring to 127.0.0.1.

share|improve this answer
    
After I change the hosts file, save it, then flush the cache, Network Util immediately shows "Proto:tcp4 Local Address: w9.hitbox.com.ipp Foreign Address: (asterisk).(asterisk) state: LISTEN. It also shows the same for udp4 without LISTEN. I've not connected to the internet after a fresh install of the OS and changing the hosts file. –  Javy Sep 19 '11 at 14:25
    
@Javy Try doing your own reverse DNS lookup on localhost... perhaps your configuration file is making it look like your computer's name is w9.hitbox.com. –  Jeff Ferland Sep 19 '11 at 14:27
    
Not sure how to do that :( Please see my edit above to the question. I added more details. –  Javy Sep 19 '11 at 14:30
    
In Network Utility's lookup tab, with w9.hitbox.com.ipp it shows the following: ; <<>> DiG 9.6.0-APPLE-P2 <<>> w9.hitbox.com.ipp +multiline +nocomments +nocmd +noquestion +nostats +search ;; global options: +cmd . 10800 IN SOA a.root-servers.net. nstld.verisign-grs.com. ( 2011091900 ; serial 1800 ; refresh (30 minutes) 900 ; retry (15 minutes) 604800 ; expire (1 week) 86400 ; minimum (1 day) ) –  Javy Sep 19 '11 at 14:43
1  
Take the w9.hitbox.com address out of your hosts file, flush your cache, and run your network utility again. I'm almost certain your system is referring to itself as w9.hitbox.com. You have a service listening on the IPP port, and that's pretty common for OS X. –  Jeff Ferland Sep 19 '11 at 14:47

You might also try using a different 127.* address for your blacklisting, e.g., "127.0.0.13 w9.hitbox.com". The entire 127.0.0.0/8 subnet is reserved for localhost so you can use anything, and using something other than .1 may be enough to avoid your host quoting the wrong name for "localhost" things. (Or it may not. I've seen it work both ways.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.