Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My local dev setup is mapping things like http://mydomain.dev/testhtmlpage to testhtmlpage.html and http://mydomain.dev/testphppage to testphppage.php. The browser stays on the orginally enter URL. The thing is I didn't configure my machine orginally and although I have a decent handle on it now I can't find where this behaviour is being defined.

I've checked my httpd.conf and the two included areas with no luck.

My httpd.conf: http://denishoctor.me/myhttpdconf.xml (view source)

In Include /private/etc/apache2/other/*.conf:

<IfModule php5_module>
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

<IfModule dir_module>
    DirectoryIndex index.html index.php
</IfModule>

Anyone got any ideas?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

This can be caused by a number of things, from rewrite rules to content negotiation. Judging by your httpd.conf, the reason in this particular case is because you have Multiviews turned on.

Excerpt from your config:

Options Indexes FollowSymLinks MultiViews

Change it to this and restart Apache:

Options Indexes FollowSymLinks
share|improve this answer
    
Thats was it! Thank you. httpd.apache.org/docs/2.2/content-negotiation.html#multiviews –  Denis Hoctor Sep 20 '11 at 3:58
    
@DenisHoctor you're most welcome :) –  John T Sep 20 '11 at 4:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.