Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My 2011 MBP has developed an annoying habit of rebooting during each first attempt to start it up. I've enabled FileVault, so once I've typed in my password, it will get to the spinning grey icon and then wait there, until eventually rebooting. On the second attempt, after I type in my password again, it will successfully start-up, and much faster than the first attempt.

I've tried a couple of things:

The first was to hold down shift before I enter my password, on the assumption that this would put it in 'safe-mode' and fix the start-up process. I did this, and after entering my password I saw a progress bar under the spinning icon, but was then returned to the normal desktop, and it didn't resolve the issue on subsequent start-ups.

I also put it in verbose mode, and saw the word 'corrupt' but then it rebooted so I didn't have a chance to write it down. I understand that this stage it's rebooting at is the launched process stage, and I've read that it could be due to a corrupted kext (not entirely sure what they are) Is the verbose output logged in the console anywhere? Any quick way to find it?

share|improve this question
1  
Do you have parallels Desktop installed? There's a recent cnet article about "double-booting," but I'm not sure if it's your particular issue. reviews.cnet.com/8301-13727_7-20106682-263/… –  Vervious Sep 21 '11 at 0:56
    
@Nano8Blazex I think it's highly probably that that's the issue I'm experiencing. Though it's an MBP not an air, and it's definitely doing a full reboot after I've typed in the credentials. I'll try using those tools mentioned when in Safe mode. Although, as mentioned above, I couldn't get into safe mode properly last time I tried. Thanks for the tip, I'll update in comments if this is indeed the problem, and invite you to submit this as an answer. –  purpletonic Sep 21 '11 at 18:48
    
Definitely a Parallels problem with FileVault. The latest update to Parallels 7 (7.0.14922) seems to have fixed it - kb.parallels.com/112281 - if you want to submit this as an answer @Nano8Blazex then I'll mark it as resolved. Thanks for your help. –  purpletonic Sep 22 '11 at 11:00

1 Answer 1

You can tell it to boot into Single User mode by doing the following:

sudo nvram boot-args="-s"

In Single User mode the system will boot the core OS and stop at a prompt. Without much Unix experience you won't be able to do much, but you may at least be able to see what is failing. To boot normally, enter the following:

sudo nvram boot-args=""
exit

It sounds to me like it's either Parallels Desktop causing it, or your hibernate file is corrupted. Though that should fix itself.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.