Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a sony vaio laptop, with ubuntu 11.04 and windows 7 on it. I have configured a VPN connection on ubuntu, in order to connect to my computer at work but it keeps not working, and I get the error VPN connection failed.

In windows 7, from the same laptop it works fine. Also, I tried to connect through linux-VPN from another wireless network, at a friends house, and it worked.

At my house, I have a linksys router and I have tried it with and without ethernet cable. What can be the problem? Maybe a setting at the router? I've searched them and they look fine.. any suggestions?

About the software, on ubuntu I use the network manager pptp, and on windows, I use the default, I didn't make any change, just created a VPN, inserted my username password, host IP and worked.

Here are the settings for the windows VPN that works:

Type of VPN: automatically

Encryption: required

Protocols permited: It mentions that it will use EAP-MSCHAPv2 as IKEv2 type VPN and has some options to chose for other types VPN. The choosen are the following: CHAP, Microsoft CHAP version2 (MS-CHAP v2)

Tab network: enabled: TCP/IPv6, TCP/IPv4, File sharing for files and printers for Microsoft networks, Client program for Microsoft networks

Also, in order to setun the VPN on ubuntu, I followed these steps bellow except for the STEP 4, because I didn't know the internal IP and some other settings

share|improve this question
the only thing i can think of is hostname and the vpn trying to auth as user@host.domain. not definitive, but it's my best guess. – RobotHumans Sep 20 '11 at 14:17
Yes, you are right, it may be this, because for this VPN I have to give as username only my username, without @host at windows. Do you know how could I try restrict linux doing this? – Kallia Sep 20 '11 at 16:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.