Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a hard time reading the Mathematica journal online, since the fonts are too small, and I'm not able to download the CDF files.

When I go to mathematicajournal.com and click on CDF, it opens inside the browser. But the "increase font size" option I have on my Firefox has no effect on the size of the fonts used by the CDF. So it stays too small for me.

I can't download the CDF, since when I right-click on the 'cdf' link, I do not get an option to download the target as normally I do with other files. It only opens in the browser, and once it does, I do not see how to download it or change the font size.

Maybe someone here knows how to either increase the font size while in the browser, or download it. (Once I download it, I can open it in Mathematica, then I can increase the zoom there to see it better).

share|improve this question

migrated from stackoverflow.com Sep 20 '11 at 11:36

This question came from our site for professional and enthusiast programmers.

    
BTW when I right-click on the CDF download icon I'm presented with all kinds of options, among with the option to download said file. Download went fine. –  Sjoerd C. de Vries Sep 20 '11 at 6:28
    
If you go (in Firefox) to Edit > Preferences > Applications you should be able to change the behavior for the CDF file type... Maybe you can then get the context menu to work properly. Of course, if you're really having trouble downloading it, you can extract the link from the page's html source. –  Simon Sep 20 '11 at 6:31
    
And changing font size works just fine in the browser. The usual pinching on the pad, or ctrl scroll: no problem –  Sjoerd C. de Vries Sep 20 '11 at 6:31
    
@Sjoerd: The keyboard shortcut for that is Ctrl-+, but does that work for embedded CDF? I just tried on my gf's Mac and it didn't... –  Simon Sep 20 '11 at 6:32
    
Just tested zooming embedded CDF in firefox and IE in a virtualbox install of WinXP... didn't work there either. Although right-click download works fine in both. –  Simon Sep 20 '11 at 6:51
show 3 more comments

3 Answers

up vote 3 down vote accepted

Both pinch zooming and ctrl-scroll work for me on FireFox, ctrl-plus doesn't:

enter image description here

enter image description here

share|improve this answer
    
on windows 7, CTRL+ did not work for me, clicking on firefox little '+' at the top left corner, which does magnify other pages did not work, this is firefox 6.0.2. But what did work is click on CTRL, then move the small wheel in the mouse. I never used that until you just mentioned it. Lucky I have a mouse with small wheel in it :). Thanks for your help. –  Nasser M. Abbasi Sep 20 '11 at 8:57
    
@Nasser ctrl-scroll is something that works for many programs. For instance, in Excel you can quickly get an overview of your sheet that way. –  Sjoerd C. de Vries Sep 20 '11 at 9:03
    
@Sjoerd: Ok, Ctrl-Scroll works for me. It's interesting that the zoom is happening at the level of the plugin and not the browser. I guess since Ctrl-+ is reserved for other things in Mathematica, it is not set up for zooming in the cdf reader. (Btw in the reader, ctrl-scroll changes the zoom% menu in the bottom right - but that menu is not available in the plugin). –  Simon Sep 20 '11 at 9:06
add comment

Update to Simon's answer for Windows 8/7/Vista:

The location of the plugin initialization file for the stand-alone player is

C:\Users\USERNAME\AppData\Roaming\MathematicaPlayer\Autoload\PacletManager\Configuration\FrontEnd\init_VERSION.m

and the location for the player installed along with Mathematica is

C:\Users\USERNAME\AppData\Roaming\Mathematica\Autoload\PacletManager\Configuration\FrontEnd\init_VERSION.m

The apparent size of the player is controlled by adding the line

Magnification->1.5

with a comma either before or after to separate it from the other options. In practice the number used should be less than the actual Windows desktop magnification to avoid clipping of the displayed image by the embedding area.

These files get overwritten when the plugin exits naturally. This can be prevented by making the files read-only after editing, with no apparent error messages or problems.

share|improve this answer
add comment

So you need to change the Notebook or $FrontEnd option Magnification, but (as far as I can tell) you can't do that from within the Wolfram CDF player or CDF browser plugin.

The standard init.m files work for the cdf reader, but do not work with the plugin. However, there is an init file used by the plugin. In my WinXP test install (because there's no plugin for linux yet...) the file that you want is C:\Documents and Settings\USERNAME\Application Data\MathematicaPlayer\Autoload\PacletManager\Configuration\FrontEnd\init_8.0.3.0.m Where the numbers will change as the version changes. There is no file in the C:\Documents and Settings\All Users\ version of the directory structure... but maybe it would work if you created one.

Anyway, in the default install, my file contained

SetOptions[$FrontEndSession,
PrivatePaths -> {"SystemResources" -> {ParentList}, 
  "TextResources" -> {FrontEnd`FileName[{"C:\\Program Files\\Wolfram \
Research\\Wolfram CDF \
Player\\8.0\\AddOns\\Applications\\WolframAlphaClient\\.\\FrontEnd", 
      "TextResources"}, "PacletManager" -> True, "Prepend" -> True], 
    ParentList}}
]

Just add the Magnification that you want to the SetOptions and save, e.g.

SetOptions[$FrontEndSession,
PrivatePaths -> {"SystemResources" -> {ParentList}, 
  "TextResources" -> {FrontEnd`FileName[{"C:\\Program Files\\Wolfram \
Research\\Wolfram CDF \
Player\\8.0\\AddOns\\Applications\\WolframAlphaClient\\.\\FrontEnd", 
      "TextResources"}, "PacletManager" -> True, "Prepend" -> True], 
    ParentList}},
Magnification->1.5
]

Then restart the cdf plugin and reload the cdf document that you want.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.