Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Windows XP with VMware Fusion on my MacBook and while internet works, Windows can ping the Mac, etc. from the Mac or any other machine in the network we can not see the Virtual Machine. In between, I use bridged option and obtain the the VM's IP dynamically; tried also static assignment from the free addresses but the problem persisted.

Any ideas what is wrong?

share|improve this question

migrated from stackoverflow.com Sep 1 '09 at 17:48

This question came from our site for professional and enthusiast programmers.

    
Are the IPs you are receiving from your ISP or local to your network? –  Chealion Sep 16 '09 at 4:13

2 Answers 2

It must be an issue with Windows Firewall

Control Panel --> Windows Firewall --> Advanced --> ICMP Setting --> "Allow incoming Echo request"

share|improve this answer

I am assuming that you are using IP addresses to ping with, and not the hostname (if the latter then you have a hostname resolution issue).

For the former, it is most likely a firewall issue. When Windows firewall is on (as the default settings) in Windows XP computer, it will not respond to ping requests, so obviously you can’t ping to the particular computer. You will be getting ‘Request Time Out’ reply from the destination, even though its connected and accessible in local network. The reason behind is that the ICMP packets, which are used in ping command, are blocked in default firewall rule in Windows XP. The 'pinging' host sends ICMP packets to the destination and waits for the response. When the destination computer doesn’t acknowledge or reply these packets you will be seeing ‘Request time out’ reply.

There are two methods by which you can enable ping, or ICMP Requests, in XP.

1) Completely switching off the firewall service (This is not recommended in most cases)

2) Only enable ICMP packets (excepting ICMP packets in Firewall rule), so while firewall is on ping requests also will work. You can do this thus:

a) Go to Network connections in Control panel;

b) Right Click the connection you want to enable ICMP/Ping requests (normally local network);

Right Click Properties

c) Click Properties;

d) Go to Advanced tab and press Settings button under Windows Firewall;

e) Press Settings button in ICMP area, and finally;

ICMP Advanced

f) Enable the tick in ‘Allow incoming echo…..’. Press OK.

Enable ICMP

Now this computer will accept ping ICMP echo requests and reply to them.

By enabling Echo or ICMP or Ping requests by this method without completely switching off the firewall, the computer will be safe in network and reply to ping/ICMP requests. That will allow you to monitor and manage IP address and hosts on your network.

Source: How to enable ping in XP

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.