Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have one Windows 7 workstation which is re-sizing application windows either on, during or after the screen automatically locking (can't tell at what point as you only see the change after unlocking the workstation.)

The symptoms look very similar to the screen resolution being decreased, except that the icons don't move to the constraints of what would be the resolution.

Example after screen lock

I have tried changing the resolution, updating the display adapter and monitor drivers, a different graphics output, cables (DVI and VGA) and several restarts (this has been ongoing for a month or so.)

It is a single monitor work station.

share|improve this question

2 Answers 2

I have never encountered this problem, so can only comment upon it theoretically.

However, a quick search has found that you are not the only one having it, and that many people consider it to be a Windows bug. Indeed, this stackoverflow article even discusses how to program to counter this bug.

I would therefore first update your video driver to the latest version, downloading from the manufacturer's website.

Another advice that might apply is to Disable Aero Snap Auto Maximize and Arrange Window in Windows 7.

This other SU article advises a far-fetched advice :

Some people reported that this issue was caused by TMM, a service installed on Vista, you can disable it under Control Panel > Administrative Tools > Task Scheduler > Microsoft > Windows > MobilePC.

If you have a portable computer, the article Close lid on laptop changes screen resolution gives an advice that might have some weak connection to the problem :

Go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video and find all the keys named “LidBehavior“ anywhere under this folder. For each LidBehavior, change the value from 11 to 10. Reboot.

share|improve this answer
    
Thanks for the advice. The computer in question was shutdown for the weekend by its user so I can't try them from home, will work through the suggestions during the working week and report back. –  Windos Sep 24 '11 at 21:52

Try this, I can't reproduce your problem so I can't check for success. Place your windows, one for each application where you want them. E.G. Full screen for Word, a smaller window for IE in the center of the screen, whatever then close each of them in turn by pressing the control key and clicking the X in the top right. Reopen the app and check it opens in the same place and same size as it closed. The control-'X' bakes the settings into most well-behaved programs as well as performing certain other background and housekeeping tasks. Now try to replicate your problem.

share|improve this answer
    
Unfortunately, this didn't do the trick. –  Windos Sep 24 '11 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.