Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am doing some project work and for that using the server at college with SSH connection.

Every time I try to open emacs on the terminal after connecting, it opens emacs in the terminal itself I.e. not its own window. On my laptop on which Ubuntu is installed, emacs always opens up in its own window an thats how I am used to it. There are several problems when it opens in the terminal like when I try to use commands such as M-V, actually terminal's view menu opens up, its very frustrating. Also I am pretty sure that the college server runs on red hat and has X installed on it. So what do I need to do to get my emacs window back.

EDIT: I finally got a solution for this nagging problem, so I though I'd share it. Just go to the edit->Keyboard shortcuts and disable the menu access keys. Problem solved, no need to open emacs in its own window. Source : http://draptik.wordpress.com/2010/01/15/using-basic-emacs-keybindings-in-gnome-terminal/

share|improve this question
add comment

2 Answers 2

does your server forwards X.? if yes , you may try to log in with '-Y' option to ssh

ssh -Y me@myserver

share|improve this answer
    
In addition, using xemacs instead of emacs might be helpful. –  BennyInc Sep 21 '11 at 7:13
1  
@BennyInc: Note that xemacs is a different program from GNU emacs running in X. There was a fork owning to deep disagreements about the proper direction of emacs development. The two branches have developed similar capabilities but the remain distinct. –  dmckee Sep 21 '11 at 13:28
    
@BennyInc OP has only one choice of using what was installed on server. –  kindahero Sep 22 '11 at 3:31
add comment

well, what about another terminal emulator without conflicting hotkey? i guess there are some.

though, there is a terminal-based solution, if to run remote emacs in a new terminal window is all you need.

#not sure which terminal emulator you are running, so i'll say gnome-terminal

invoke terminal emulator by such command to ( ssh and start emacs on remote host ):

gnome-terminal -e 'ssh HOSTNAME emacs'

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.