Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a Linksys WRT160N wireless router as an access point in order to extend the effective range of a working Belkin wireless router that has internet access.

I don't know the model of the Belkin router, but is what the router access screen looks like @ 192.168.2.1:

The wifi is unsecured and is giving out IP addresses. The DHCP range is 192.168.2.2 through 192.168.2.100. There is no time limit on the lease either.

I've tried a couple of setups on the WRT160N but could'n get any configurations to make the Linksys behanve as a wireless access point.

The most reasonable configuration, in my opinion, was to give the WRT160 a fixed IP of 192.168.2.99, turn the DHCP of the wireless access point off, and use 192.168.2.1 (Belkin WiFi) as the gateway & dns servers.

I have a similar set up in my house where I set up a wireless router with static IP and DHCP disabled to act as an access point. It obtained the "internet" through one of the 4 wired ethernet jacks on both routers and not via WiFi. That's the only difference, I suppose. I need the internet "feed" to be obtained wirelessly rather than through a wired connection.

What am I missing?

I have been reading manuals and Q&A sites about the issue but could not find the right help.


EDIT:
I don't have access to any piece of hardware except for the Linksys WRT160N. The other pieces I am trying to connect to/bridge with are in an inaccessible area. I cant run wires to or from them, I can only connect to the router via a browser wirelessly.

share|improve this question

migrated from serverfault.com Sep 21 '11 at 3:57

This question came from our site for professional system and network administrators.

    
What you need is a wireless range extender (repeater), not a wireless router. I'm doubtful that the model you have can act as a repeater, but it might. You'll need to dig into the documentation to see. –  joeqwerty Sep 21 '11 at 3:00
    
@joeqwerty with DD-WRT, it can function as a repeater (I used the same router to do just this). –  Breakthrough Mar 4 '12 at 17:07
add comment

2 Answers 2

First of all, if you can just take it back to the store and get an access point.

That being said, all you should have to do here is disable DHCP on the WRT160 and give the device a static IP address in the same subnet. If it want's a default route it should be the IP of your other router. You should have a cable from one of the LAN ports of your existing wireless router to one of the LAN ports on the WRT160. The WRT160 should then simply act as an access point, layer 3 connectivity will be serviced by the other router.

Alternatively, you could change the IP scheme of this new access point to something like 192.168.3.x/24 and connect the WAN port to the existing router and you'd also be done. Lots of options.

I just noticed your comment regarding the need for this to be a wireless extender/bridge. Read the manual or run a cable.

share|improve this answer
    
and my quick look at the owners manual shows no wireless bridging/extending options in the wireless setup. I use Apple airport express devices to do this in consumer applications. –  SpacemanSpiff Sep 21 '11 at 3:17
    
The WRT160N is actually four different routers (with two very different designs). Can you check your actual version? (1.0, 1.1, 2.0, or 3.0) Also, can you clarify how you're trying to use it? (Will it be connected by wires or wireless to the existing access point? Will it have local wired devices connected to it or just be a wireless repeater?) –  David Schwartz Feb 1 '12 at 18:21
add comment

I have a Linksys wrt160 V2 router and I set it up as an access point by running an ethernet cable from my main Belkin router which is directly connected to my Motorola modem into one of the four blue ethernet out ports. I disabled the DHCP Server and changed Internet Connection Type to Static IP under Setup/Basic in the router menu. That is all I did to make it work. See the attached image for settings...

Sorry I wasn't allowed to add an image which would have have been very helpful.

share|improve this answer
    
thanks for the info, but i guess i wasn't specific enough in my question... read edit –  CheeseConQueso May 11 '13 at 19:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.