Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed Windows 7 on my laptop. I want to be able to log in using RDC quickly. If I failed to log out or disconnect prior to walking away from my laptop, when I attempt a RDC connection it pops a confirmation dialog up on the laptop and won't connect the RDC connection for 30 seconds unless the confirmation dialog is used.

Is there a way to disable this?

share|improve this question
    
Why is your laptop terminating the connection when you walk away in the first place? Does RDC terminate when the screen locks? –  Will Eddins Sep 1 '09 at 19:19
    
@Will: I think he's talking about walking away from his laptop and then RDC-ing into it from another place. –  fretje Dec 11 '09 at 19:01
    
Could you post the exact error message or a screenshot of the confirmation dialog? –  Shoeless Dec 13 '09 at 20:43
add comment

3 Answers 3

up vote 2 down vote accepted

using Local Group Policy Editor (gpedit.msc) there is a setting under :

Administrative Templates \ Windows components \ Remote desktop services \ Remote desktop session host \  Connections

saying "Set rules of remote control of remote desktop services" witch lets you specify the interaction mode and the control level for an RDP session

enable it and choose the "Full control without user permission" option. so the logged user won't be prompt for confirmation (there is more details there)

you can also set the Session time limit for active but idle RDP service under session time limit folder to "Never" and it won't disconnect you you IDLE.

share|improve this answer
    
Can you clarify the last part... I did not find "session time limit" anywhere. Instead I found a folder called "session time limits", but the settings there are not exactly what I am looking for. What I want is to change the 30 second to larger value. Is this possible? –  Juha Aug 17 '11 at 13:06
    
@juha i've edited my answer. you looked into the right place (session time limit folder), you need to enable that setting and then look under the "Options" label and set the "time limit" to any other value. –  Revolter Aug 18 '11 at 5:38
add comment

This Microsoft Support article :
Remote Desktop Connection 6.0 prompts you for credentials before you establish a remote desktop connection
suggests turning off this message by text-editing the .rdp file and changing the value of authentication level to zero, like that:

authentication level:i:0

share|improve this answer
add comment

You could use an AutoHotkey script to check if the window is open periodically. Without an image of the comfirmation dialog, I don't know the exact text, but you can substitute it in my script:

SetTitleMatchMode, Slow
loop 
{
    IfWinExist, Remote Desktop Connection Disconnected ; modify this
        Send { Enter }
    else
    {
    Sleep 1000 ; wait a second, save our CPU
    }
}
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.