Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On Windows XP Professional, why does Firefox continue to show me the message that it works better if Javascript is enabled?

When I follow the directions and look in Add-ons to enable it, I find it enabled already.

EDIT: fixed Java/Javascript error. Cannot load a picture, even if it is in clipboard or saved as a file.

share|improve this question
1  
1) Is it Firefox, or web pages that show you that messages? 2) Haven't you confused Java with JavaScript? They are totally different technologies. –  jakub.g Sep 21 '11 at 14:45
    
1) It is Firefox. I'll try to upload a pic. 2) Thanks for the education. I'll edit my post. Plus 2 if I could. –  Xavierjazz Sep 21 '11 at 14:55
    
I cannot figure out how to post the pic. Can you help? –  Xavierjazz Sep 21 '11 at 15:16
1  
The thing is that some pages rely on JavaScript to do various things, mainly the asynchronous processing, displaying/hiding different part of pages etc. Type about:config in browser URL bar and see the value of javascript.enabled. If it's false, change it to true (right click -> toggle). –  jakub.g Sep 21 '11 at 15:18
    
To post the picture: imageshack.us works without JavaScript. –  jakub.g Sep 21 '11 at 15:20

1 Answer 1

up vote 1 down vote accepted

This is a message from website, not the browser. Like I said before, JS is used to do various things automatically.

In SuperUser, it is used for instance for refreshing thread contents while you browse. Browser sends asynchronous request to SU to check if some new answers were posted every few minutes, and if so, it displays a message in top of a page asking if you want to load new answers.

You can control if JavaScript is enabled/disabled by:

  1. javascript.enabled config entry setting true/false in about:config
  2. Via add-ons like WebDeveloper
  3. Adding a button after installing Toolbar buttons

and also probably other numerous add-ons.

It's strange you tell it is already enabled. Maybe some other add-ons affect the setting (most notably, NoScript).

share|improve this answer
    
Do not have "No Script". –  Xavierjazz Sep 21 '11 at 21:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.