Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Chrome no longer seems to open my application shortcuts (pinned to the Windows 7 taskbar) in a maximized window. I didn't used to have this problem -- in the past, I'd simply create a new application shortcut on the taskbar (e.g., Gmail, Google+), open the shortcut, maximize the window, close it, and Chrome would remember that I wanted that shortcut maximized next time. That's no longer the case. Seems like this functionality has been broken since Chrome 13 or 14. (At least on my system.)

My operating environment:

  • Windows 7 x64 Ultimate
  • Chrome 14.0.835.186 m
  • Shortcuts are pinned to the Windows 7 taskbar

How can I make Chrome application shortcuts start maximized? I've tried most of the supposed solutions I could find ( How to start Google Chrome with maximized window? ), to no avail.

Adding -start-maximized or --start-maximized to the shortcut target command line works perfectly for my regular Chrome shortcut, but it doesn't seem to have any effect on application shortcuts.

Anyone know how to force application shortcuts to start maximized?

share|improve this question
    
Your new to the site, so please read the FAQs... Your question really should be in three parts. One for each Operating System. when you say "at least on my system" what OS are you using? What operating system are you using? –  wizlog Sep 21 '11 at 16:45
    
I included my OS and Chrome version in the second sentence: "I'm running Windows 7 x64 Ultimate, Chrome 14.0.835.186 m". Was I supposed to put it somewhere else? I may be new to superuser, but I'm a long-time stackoverflow/stackexchange user :) –  Michael Sep 21 '11 at 17:10
    
Did you try removing it from the taskbar, and dragging the working desktop shortcut down to the taskbar to pin it? –  Rob Sep 21 '11 at 17:22
    
+1 for good question. @Michael I apologize. I thought you had written Ubuntu. I'm very sorry and did not mean to offend you in any way. –  wizlog Sep 21 '11 at 20:06
    
@Rob: I don't have a working desktop shortcut. So far I've only been using pinned taskbar shortcuts. I haven't tried desktop shortcuts at all, in fact. Perhaps I should? –  Michael Sep 21 '11 at 21:20
show 3 more comments

2 Answers

I can not solve your problem directly, but I have the best workaround possible.

You can also create desktop shortcuts for other websites and apps you regularly use, even if they're not installed from the Chrome Web Store. Follow these steps:

  1. Click the wrench icon icon on the browser toolbar.
  2. Select Tools.
  3. Select Create application shortcuts.
  4. In the dialog that appears, choose where you'd like the shortcuts to be placed on your computer.
  5. Click Create. -this guide to creating Application shortcuts has been copied from Google's support pages.

Here is what your looking for...

  1. Right click on the shortcut or menu item you use to start the program.
  2. Now, click on properties.
  3. Note the item labeled Run that's set to "Normal Window". Change that to "Maximized".

After this is done, you can drag and drop the shortcut to the start menu or taskbar and you should be fine. I tried this with Windows Vista, and it worked great. I see no reason why this shouldn't work for Windows 7

share|improve this answer
    
@Michael -- If you would like a visual guide to preforming these steps, I will upload pictures to assist you. –  wizlog Sep 21 '11 at 22:13
3  
This isn't working reliably on my system. It seems to fail if I have another Chrome window open that isn't maximized. Try this: Pin a regular Google Chrome shortcut to your taskbar. Open it, size it down (non-maximized), and close it. Reopen to confirm Chrome "remembers" your sized down preference. Now, create your application shortcut with the "start maximized" setting (it can be a desktop or taskbar app shortcut). Open the app with no Chrome windows open, and it starts maximized and works perfectly. But open the regular Chrome window first (unmaximized), then open the app, and it fails :( –  Michael Sep 22 '11 at 16:46
    
Does anyone know if it's possible to remove the windows application frame when not in fullscreen? i.e. this bit. –  GFoley83 Aug 11 '13 at 23:51
add comment

Right click on the shortcut in the task bar, right click on the shortcut name, go to Properties, under Run: choose Maximized, hit OK.

share|improve this answer
    
Unfortunately this does not work. (Although you would think it would.) Unless something has changed (bug fix?) in the most recent release of Chrome. I'll check it out and report back. –  Michael Nov 28 '11 at 17:32
    
Yes, confirmed, this does not work. Thanks for your response though. See my comment on the other answer. The issue I'm having occurs when you have another chrome window open that isn't maximized. With no Chrome windows open, a shortcut with "Maximized" set works just fine, but if you typically keep your Chrome browser non-maximized, the "Maximized" preference is completely ignored for application shortcuts. –  Michael Nov 28 '11 at 17:44
    
It worked for me on Windows 7 Ultimate. –  WordPress Developer Jul 16 '13 at 13:22
add comment

protected by Community Feb 12 '12 at 19:47

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.