Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Git for Windows doesn't seem to support the extra context menu entries for "Git GUI Here" (or "Git Bash Here") when running on 64-bit systems. Is there some other way I can get an entry for "Git GUI" to show up in the context menu so that it will open the commit interface with the current folder selected?

Edit

I saw the installer option and made sure it was checked, even reinstalled a few times. Also removed TortoiseGit and restarted the computer, but nothing seems to help. From what I could find online I got the impression you have to mess around with building and modifying msysgit yourself to get the context entries to work on 64-bit systems, which I'm not keen on doing.

share|improve this question

4 Answers 4

You can just type: regsvr32 "%PROGRAMFILES%\git\git-cheetah\git_shell_ext64.dll" in a console window (or use Win+R).

share|improve this answer
1  
Did you mean regsvr32 -u? –  cadmium Apr 11 '13 at 16:04
    
for me I had to use PROGRAMFILES(X86) but the basic principle did work, thanks! –  rogerdpack Sep 24 '13 at 20:29
up vote 2 down vote accepted

Well I found a program called Open++ which lets you create custom context menu entries. Configure like so:

enter image description here

and then you can access in the Open++ submenu:

enter image description here

It's not quite as nice since it's in a submenu and it's always shown rather than only when you're in a repository, but it's better than having to choose your repository every time you start the gui.

share|improve this answer

I had the same problem. After installing msysgit not in the normal program directory, everything works fine.

share|improve this answer

I have Git for Windows 1.7.6 installed on my 64-bit Windows 7 system, and the context menu entries work fine for me. It is an option in the installer.

share|improve this answer
    
Yeah I saw that option but it doesn't seem to do anything for me. I added more details to the question. –  Brad Mace Sep 21 '11 at 21:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.