Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Possible Duplicate:
Can't delete folder in Windows 7

Recently I updated Windows 7 and it seems to have left a folder on my download partition under the name of 'ed4d9301c862cbea71281a6acdc7'. Now when I try to delete this folder I get the following message:

enter image description here

Now I am logged in as administrator and have full control in the Security tab. I also tried adding my username and giving myself full control over the folder as well. But nothing I tried so far has worked as it seems to be the case that only 'SYSTEM' can make changes to this folder. All this despite me having full control over this folder. Could anyone guide me into the right direction please because it seems to me I'm missing something here.

Edit: A Live CD is not an option as my DVD/CD reader/writer is not functional.

share|improve this question

marked as duplicate by Moab, Randolf Richardson, ChrisF, Tom Wijsman, Dennis Jul 11 '12 at 18:21

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I wouldn't say it's the same problem. My problem is with a folder which was created by Windows. Not by myself like the other question. My folder is not empty either. Permissions are different from folders that are unavailable or not found as well. It's quite obvious they are different. –  Citroenfris Sep 22 '11 at 21:52
    
Solution is the same, how to delete an undeletable folder. –  Moab Sep 22 '11 at 22:12
    
The rd thing doesn't work since the folder is not empty. And I can't make the folder empty because there are about 38 items/folders in it which cannot be deleted for the same reason as the original folder... –  Citroenfris Sep 23 '11 at 1:09
    
Booting from a Live CD works for any folder or file delete. –  Moab Sep 23 '11 at 4:11
1  
I think you need to edit/re-write your question and add ANY relevant information such as broken hardware. –  Moab Sep 23 '11 at 14:29

2 Answers 2

I've noticed that these folders can't be deleted until after one or two additional reboots.

It may be that after the first reboot, there are still some other things that need to be done before that directory can be removed -- unfortunately Windows doesn't seem to clean them up on its own, which is why we're all left with having to clean up after it.

share|improve this answer
2  
I will have to wait and see when I can delete it then. I've rebooted about 3-4 times already so far! Perhaps it takes a certain span of time before it unlocks. Thank you for the suggestion! –  Citroenfris Sep 21 '11 at 23:42
    
That's a good possibility. It may also depend on what the update is all about. Here's a fun picture of someone with great authority telling his daughter to clean her room: 24.media.tumblr.com/tumblr_ln2a68O6jr1qzqua1o1_500.jpg –  Randolf Richardson Sep 21 '11 at 23:53

Would "Unlocker" be of any use to you? http://www.softpedia.com/get/System/System-Miscellaneous/Unlocker.shtml

share|improve this answer
    
Does not seem to be working :(. –  Citroenfris Sep 22 '11 at 1:03

Not the answer you're looking for? Browse other questions tagged or ask your own question.