Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Lately my main PC has been going through a series of hardware failures, which is very concerning.

Some two weeks ago was the first one, in the form of bad sectors on my main hard drive. It affected my ext3 file partition, and I didn't think much of it - so I went to take on an old wish of mine, namely overclocking the CPU. I raised voltage for about 0.5v and, by changing the multipliers (didn't touch the FSB timings), I increased the frequency from 2.6Ghz to 3.0Ghz. All seemed well.

Then the bad sectors appeared for the second time, touching my Windows partition. I ran CHDSK, but to no avail. Seems that in the meantime, there appeared memory errors, preventing Windows from booting and causing live Linux distros to lose their functionality - I ended up removing two of the newer RAM sticks, leaving myself with 1GB of RAM that seemed to be stable. Despite that, it seems that on the top of all problems, there are occasional system freezes as well, affecting both Linux and Windows installations.

What's going on? Is this a set of coincidences, or have I broken something vital? Any ideas of a culprit?

P.S. Motherboard & CPU are year 2006 models; the system was built in 2007 and upgraded again in 2011. Motherboard has been taken for repair once, all other hardware has been going strong before becoming too old in comparison to today's systems.

share|improve this question
2  
Stop overclocking and see if some of the problems don't go away. –  hbdgaf Sep 22 '11 at 9:42
    
Disabling higher voltage and lowering the frequency back to 2.6 Ghz seems to be doing nothing to help with the issue, unfortunately. The system ran fine for some 5-6 days when overclocked. –  winta Sep 22 '11 at 9:49

2 Answers 2

The worst case scenario is a capacitor plague – and it's the motherboard.

In addition I'd check the RAM with memtest and the drives with smartmontools or gsmartcontrol.

Try various combinations of RAM, preferably on the first slot (which seems to work) – I've seen slots die rather than sticks of RAM. Also try swapping the power supply, to make sure it isn't at fault – I've seen systems 'die' because of that.

share|improve this answer
    
Thanks, I'll try swapping PSU & RAM sticks. Memtest turned up with hundreds, if not thousands of errors for both newer RAM sticks, the ones that I ended up removing. Nothing for the one that remained. Ubuntu's disk utility shows 22 bad sectors, at least some on files important to me (they have backups, fortunately). SMART test failed. –  winta Sep 22 '11 at 9:53
    
eh, all of those are bad things. Can you test the ram in another system ? if they still fail, see if you can RMA them. What're your numbers for the critical stuff for SMART from here ? Most things point at old age to me, at this point –  Journeyman Geek Sep 22 '11 at 9:55
    
The two other RAM sticks still turn up with errors, even in a working slot. I'll try returning them. Here are the hard drive readings: link; link –  winta Sep 22 '11 at 10:37
    
current pending sector count is bad bad bad bad. It basically there's so many bad sectors that the disk can't adjust to it. Check if its under warranty and RMA it if you can. –  Journeyman Geek Sep 22 '11 at 10:43
    
I fear it's not possible to get a replacement anymore: the HDD in question is 4 years old, and bought from some online shop which account details I don't have anymore. I'll get just a new one instead then. –  winta Sep 22 '11 at 11:13

Maybe PSU is supplying not enough power?

I had similar issues with HDD when feeble PSU was heavily loaded, therefore had some voltage drops. So HDD failed some writes (and created softbad sectors). All of them had gone after full erase cycle in MHDD.

Under undervoltage conditions, you can have issues with system memory as well.

Try installing some software to monitor PSU voltages and see how they differ under normal/heavy loads.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.