Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to copy my some files from Mac (Macbook-Air) to an USB external hard drive, formatted as NTFS.

How is it possible? Because when I do copy my files from the Mac and go to paste them on the external HD there is no option for paste.

share|improve this question
    
Yes, it is possible. Check out this question: apple.stackexchange.com/questions/447/… – user98776 Sep 22 '11 at 12:20
up vote 26 down vote accepted

The problem is that your drive is NTFS formatted. OS X can't write NTFS out of the box (at least not without some tweaks). Here are some ways to do this.

Format the drive as FAT-32

This is the obvious answer to those who don't want to install software that potentially could harm their data (which is always the case with hacks / unstable software). Re-format the drive to FAT-32, which both Windows and OS X can read and write out of the box.

This is of course not a solution for files larger than 4GiB.

NTFS-3G via Homebrew installation

If you have Homebrew, installing NTFS support is as easy as running the following in a terminal:

brew install ntfs-3g

Then, follow the instructions on the screen. Homebrew will tell you how to replace the default OS X automounter so external NTFS drives are mounted using the new driver. Those are a couple of commands you need to run through your terminal.

NTFS-3G via GUI installation

This is a free version (there's also a paid one, and the free one's a bit harder to find).

  • First, download and install Fuse for OS X and select the MACFUSE compaibility layer during the install.
  • Then, download NTFS-3G, a free NTFS driver. Download the latest version from here and install it.
  • You will have a new option in System Preferences that enables you to write to NTFS drives.

Commercial solutions

These are not free, but offer support and promise better speed/stability.

Hacks

  • There is SL-NTFS, which isn't maintained anymore, but promises to enable NTFS write support on Snow Leopard (10.6).

    Because SL-NTFS is basically an interface for configuring the Apple NTFS driver, any issues you might encounter will be related to the Apple driver rather than SL-NTFS. If you require a more robust, supported solution for writing to NTFS drives/partitions, I recommend you locate a more comprehensive solution.

  • This is a hack for enabling NTFS write support on OS X 10.6 which involves some command line tweaks. Again, use it at your own risk.


Related Super User questions

I felt those were lacking an overview of tools:

share|improve this answer

Get the latest version of MacFuse first from here.

After you install it, you will need to install ntfs-3g. This is the FUSE. You will need to make sure you have the latest versions of both, since older versions of ntfs-3g might not work with a newer version of MacFuse.

You should now be able to read AND write from your Mac to any NTFS drive.

share|improve this answer
    
Note: MacFuse is no longer under development. – slhck Feb 19 '15 at 15:29

Q. How to copy files to read-only NTFS hard drive on a Mac?

A. Enable NTFS write on the drive.

There are some excellent instructions on osxdaily.com.


Michael Dreher points out in the comments of the preceding osxdaily.com link:

(referring to this source code)

We only allow read/write mounts if the "nobrowse" option was also given. This is to discourage end users from mounting read/write, but still allows our utilities (such as an OS install) to make changes to an NTFS volume.
Without the "nobrowse" option, we force a read-only mount. Note that we also check for non-update mounts here. In the case of an update mount, ntfs_remount() will do the appropriate checking for changing the writability of the mount.

if ((vfs_flags(mp) & MNT_DONTBROWSE) == 0 && !vfs_isupdate(mp)) vfs_setflags(mp, MNT_RDONLY);

--

Tested: Solution is confirmed working on everything from Maveriks to El Capitan.

About El Capitan:

De says: September 10, 2014 at 10:10 am

If the other solutions don’t work – the following does a 100%:

mkdir ~/Desktop/Drive // where the drive will be mounted mount // will tell you the internal drive name, something like /dev/disk2s1 sudo umount /dev/disk2s1 sudo mount -t ntfs -o rw,auto,nobrowse /dev/disk2s1 ~/Desktop/Drive Reply

Jo says:
The only solution that worked perfectly, thanks !

gia says:
Excellent solution, works for NTFS in OS X El Capitan and OS X Yosemite

The site I referenced is very rich with all kinds of troubleshooting and debugging scenarios.

I won't try to re-create it. Before starting, reading through the article and the comments would be good to do, notably the later ones that deal with El Capitan.

Keep track of your permissions.

Make an NTFS folder (on the NTFS drive) to transfer into that has the least restrictive settings (read/write/update for everyone). Once you've had success you can try out more restrictive options.

Caution: Be very careful with syntax when using fstab.

There is confusion with users of OS X because apple removed their fstab file. You simply need to create one.

  • I've created a fstab files on El Capitan. It works well.

Fastest and "proper" solution.

  • This solution can make all your NTFS drives automount the way you want.

  • This solution can also give you access to the rest of the powerful mounting features of fstab.

  • No 3rd party software.

  • This solution (controlling the fstab file) is very portable. Fstab itself is a very common standard in computing among *NIX machines, from UNIX, OS X, BSD, Linux.. and dates back to Unix V8 at the latest. (+ 31 years).


Additional references:

Fstab file detailed info and explanations (linux flavor).

Fstab wiki info.

man fstab


A2. You could also install OSXfuse via Homebrew.

This is a common third party solution.

Here are instructions on Ask Different

share|improve this answer

You must log in to answer this question.

protected by Community Oct 8 '12 at 18:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .