Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to configure portable PuTTY to access an Accu COBOL application.

The problem is that the right mouse button click causes an unexpected character entry in the application for careless (read "not power user") users.

Accu COBOL uses /etc/a_termcap to control terminal properties. The version running on our system did not have an xterm entry. I found a model xterm with mouse control in an Accu COBOL 85 user's manual PDF and added it to /etc/a_termcap.

Unfortunately, it is not commented and I can't identify the mouse related settings. I need a configuration setting to tell PuTTY to ignore a right click unless the shift key is held down. Any help?

share|improve this question
add comment

1 Answer

Under Configuration → Window → Selection → Action of mouse buttons, choose the "Windows" mode, then save this to the default session.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.