Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have VMware Player, and I run Ubuntu with it on my Windows 7 system. Now I want to copy some files from my Windows folders into the VMware virtual hard disk, so that I can view these files on Ubuntu.

How do I do that?

share|improve this question

migrated from stackoverflow.com Sep 22 '11 at 16:10

This question came from our site for professional and enthusiast programmers.

Mount a shared folder that's on the Windows host onto Ubuntu. That way you don't even need to copy them.

Go to Virtual Machine » Virtual Machine Settings » Shared Folders.

share|improve this answer
    
+1 Didn't realize there was a setting in VMware for Shared Folders. Works for Windows to Windows VMs as well. – Thick_propheT Jan 14 '14 at 23:15

The easiest way to do is to install the VMware Tools in Ubuntu, then you are able to drag the file into the Ubuntu VM.

To install VMware Tools, you need to switch to Ubuntu, then go to the VMware menu VM » Install VMware Tools, and then follow the instructions to finish the installation.

share|improve this answer

If you don't manage to configure a shared folder, or just really want a separate copy inside the VM, you can also just rightclick->copy in the host and paste in the guest. At least that works here with VMware player, windows 7 (host) and linux mint (guest).

share|improve this answer
    
Your virtual machine should have the vmware tools installed in order enable this simple copy/past, otherwise it wont work. – Anix PasBesoin Jul 14 at 21:41

Login to your linux machine (ubuntu) in vmware. Click on "Places" and go to "Network" . Go inside "Windows Network" and go deeper and you will find "user" and then "Public" . This folder is nothing but your windows "Public" folder. You can use this folder as a shared folder between host and guest machine.

share|improve this answer
1  
I can't get this to work.  Are you sure you aren't leaving something out (like configuring your Windows "Public" folder to be shared on the network)? – G-Man Jun 20 '15 at 19:17

If no suggestions works, put your files in a FAT32 formatted pendrive. You'll see Mass Storage Device icon in bottom right corner of you VM window. Right click press Connect(Disconnect from Host).

Works!

share|improve this answer

Login to your Ubuntu in VMware. Click on Places and go to Network. Go inside Windows Network and go deeper and you will find user and then Public.

This folder is nothing but your Windows Public folder. You can use this folder as a shared folder between host and guest machine.

share|improve this answer

You must log in to answer this question.