Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a wireless router (buffalo airstation) and several boxes connected to it by wire. I can ssh between them, e.g.:

box1$ ssh box2
box2$

if, however, box1 is connected wirelessly, ssh box2 fails with No route to host. (ssh, wget, firefox &c to the internet work fine with both wireless and wired connections). ping box2 fails with Destination Host Unreachable. (name box2 is resolved to the correct IP address by both ping and ssh, probably because they are specified in /etc/hosts).

when box1 is connected by wire ifconfig prints:

eth0      Link encap:Ethernet  HWaddr 00:90:f5:80:d8:dc  
          inet addr:192.168.7.101  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::290:f5ff:fe80:d8dc/64 Scope:Link

wireless:

wlan0     Link encap:Ethernet  HWaddr 00:21:5c:46:e6:a5  
          inet addr:192.168.7.103  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::221:5cff:fe46:e6a5/64 Scope:Link

note that this is for the client box1 which initiates the connection; the server box2 which is pinged is always wired:

eth0      Link encap:Ethernet  HWaddr 00:50:ba:c8:0d:c7
          inet addr:192.168.7.100  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::250:baff:fec8:dc7/64 Scope:Link

Again, note that both wired and wireless connections work perfectly when accessing the internet behind the the router.

So, how come I cannot connect to the wired box2 from wireless box box1?

share|improve this question
    
Can you post a netstat -rn from box when connected by wireless? –  Paul Sep 23 '11 at 6:00

1 Answer 1

Check the settings on your router, look in the wireless setup, or advanced wireless setup, look for an option possibly named "WLAN Partitioning". (my DIR-655 has this) It prevents wireless systems from seeing or contacting any other computers on the router. So wired machines see each other, but wireless machines are 'partitioned' off and prevented from talking except to internet.

share|improve this answer
    
on my buffalo airstation I unchecked the box "Separate feature" under "wireless config"/"basic" and it works now! –  sds Sep 23 '11 at 22:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.