Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an Intel Wireless WiFi Link 4956AGN wireless adapter in my Laptop. When I'm running Windows Vista, it cannot see the 5ghz network that my wireless AP is broadcasting.

I know that my wireless card should be able to find the 5ghz band for two reasons. The first is the theoretical reason, that the wireless card claims to support both A and N. A being a standard that only uses 5ghz, it has to be able to use the 5ghz band. The second is a practical reason. I dual-boot into Debian Linux on this machine, and when I'm in Linux, I can connect over the 5ghz band just fine.

I've also made sure that my drivers are up to date in Vista.

This rules out pretty much every fix I've found over the internet and SuperUser. I know that my router/AP is broadcasting, and that my wireless card is capable of connecting. So, my question is: What else could be going wrong? What are some steps I can take to try to connect over the 5ghz band?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

For anyone who comes across this. I have solved the issue. While I had checked all of my router settings I neglected to check every one of my wireless card's settings. My wireless card was an Intel Wifi AGN 4965 wireless card, so these instructions may be somewhat specific to this card, but I think the theory behind it applies.

To fix the issue I went to the device manager (start menu -> right click on computer -> click properties -> click device manager) and found my wireless card. In the settings, under advanced, there is an option that allows you to choose your wireless mode.

I may have overlooked this before, since none of the options include n at all. The fix was a simple as choosing 802.11a/b/g instead of 802.11b/g. I think the reasoning behind this is that since b and g only use the 2.4ghz band, the wireless card was not searching for the 5ghz range at all. Including a, which operates only on the 5ghz band made the card look for the 5ghz band.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.