Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I plugin a USB memory device in one of my USB ports Windows 7 (32-bit) tells me this device can run faster. I tried several devices and all ports.

I found that the device manager doesn't list an Enhanced Universal Host Controller.

I tried removing all USB Host controllers and they automatically installed again but nothing changed.

How can I enable USB 2?

I have a SuperMicro C2G41 motherboard.

share|improve this question
1  
Have you tried installing the chipset drivers from the SuperMicro site? –  James Sep 23 '11 at 9:11
    
Yes, downloaded the installer. It ran through the wizard and said me everything was installed. I guess if it didn't require a reboot it detected that my system is up to date and didn't actually install anything? –  Koen Sep 23 '11 at 9:16
1  
Have you checked your BIOS to see if there are any options for USB? A few motherboards do have some obscure settings. Have you tried different cables? –  James Sep 23 '11 at 9:23
    
Didn't touch the cabling. Didn't open my machine (desktop PC). I'll check the BIOS options now... –  Koen Sep 23 '11 at 9:24
    
No I meant the USB cables you are using to connect the devices. –  James Sep 23 '11 at 9:25

1 Answer 1

up vote 2 down vote accepted

If the correct drivers are installed then it it is worth checking in the BIOS as some motherboards have an option in the BIOS to choose the USB mode (on this motherboard it would support USB 1.1 or USB 2.0)

share|improve this answer
    
You were right James. BIOS had an option "Enable USB 2.0 controller" which for some reason was switched off. –  Koen Sep 23 '11 at 9:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.