Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My computer is connected to a domain. The time is consistently wrong, in fact it seems to be going fast. I try setting the time correctly but within the hour it's changed back. I am pretty sure it must be getting the time from the server on the network.

Is there a way I can prevent this from happening? Such as insisting it syncs with Microsoft ?

share|improve this question

3 Answers 3

up vote 7 down vote accepted

By default, Windows as a domain member synchronizes against the domain controller's clock. If you're getting incorrect times, there may be two possible causes for it:

  1. The domain controller's clock is off.

    In this case, you can force Windows to synchronize against a public NTP server instead (such as pool.ntp.org). However, this will create large differences between your computer's and the domain controller's clocks, which is most likely to result in completely broken domain logons. AD uses Kerberos for authentication, and only allows time skews of up to 5 minutes.

    Fix: Scream at Talk with your network administrator.

    Workaround: Change the timezone to compensate for the offset.

  2. The domain controller's clock is correct, but your computer is configured with an incorrect timezone.

    Time sync works with UTC time. Windows always keeps its internal clock in UTC time as well, but applies an user-specified "time zone" offset when displaying times. If you see the clock as off by exactly one hour (or several hours), you might have an incorrect time zone configured.

    Fix: Go to Adjust Time and Date, verify the timezone settings.

share|improve this answer
1  
Yeah, I'd recommend not trying to change the time on your computer without the admins. It spams our logs and it isn't like you can play dumb either. . . –  surfasb Sep 24 '11 at 1:36

First, check the time in your BIOS and make sure that it is correct. If you find that the BIOS clock is correct, try disabling the Windows Time Service and then rebooting.

share|improve this answer

As counter intuitive as it seems I've had a few situations where this has happened due to a weak bios battery. Windows only checks against the time server periodically - i seem to think this is once a month, so its likely to be an internal clock issue. Get that battery swapped, especially if its an older system

share|improve this answer
    
It's weekly by default, and the BIOS battery does not affect the clock of a running system. –  grawity Sep 23 '11 at 15:23
    
For some reason, practically, i've seen that happen at least two or three times. It shouldn't happen, but it does. –  Journeyman Geek Sep 23 '11 at 23:08
    
@JourneymanGeek: Correlation != Causation. We prefer correct answers. –  surfasb Sep 24 '11 at 1:37
1  
Lets see, is it harmful? no. Does it repeat another answer - no. Has it fixed the issue in the past?... oh why yes, and even repeatably. Its also inexpensive, harmless, and has worked, and i've made it clear its personal experience and i don't know why it works. I don't see how my answer is 'incorrect' - grawity's answer is better, but its an alternative worth trying if other things don't work –  Journeyman Geek Sep 24 '11 at 1:52
1  
that wasn't mentioned in the original question –  Journeyman Geek Sep 26 '11 at 7:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.