Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How can I open other ports than HTTP and HTTPS using SQUID proxy? I have last version of squid running on Fedora 10 but I'm not able to open FTP port.

my squid.conf:

acl manager proto cache_object
acl localhost src ::1
acl to_localhost dst ::1

acl ftp proto FTP
acl ftp_port port 21
always_direct allow FTP

acl SSL_ports port 443 20 21 22
acl Safe_ports port 20      # ftp
acl Safe_ports port 21      # ftp
acl Safe_ports port 22      # sftp
acl Safe_ports port 80      # http
acl Safe_ports port 280     # http-mgmt
acl Safe_ports port 443     # https
acl Safe_ports port 1025-65535  # uregistred ports

http_access allow manager localhost
http_access deny manager

# USER privilegies (encoded in file passwd)
auth_param basic program /usr/lib/squid/ncsa_auth /etc/squid/passwd

# BLACKLIST (in file denied.conf)
acl denied_domains dstdomain "/etc/squid/DNDdomains.conf"
acl denied_regex url_regex "/etc/squid/DNDregex.conf"
http_access deny denied_regex 
http_access deny denied_domains

http_access allow AUTHUSERS
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow ftp_port CONNECT
http_access allow ftp
http_access allow localhost
http_access deny all
#http_reply_access allow all
#http_access allow all

http_port 3128
hierarchy_stoplist cgi-bin ?
cache_dir ufs /var/spool/squid 10000 16 256
coredump_dir /var/spool/squid
refresh_pattern ^ftp:       1440    20% 10080
refresh_pattern -i (/cgi-bin/|\?) 0 0%  0
refresh_pattern .       0   20% 4320

What am I doing wrong?

UPDATE: http_access aloow ftp -> allow (replaced)

share|improve this question

A quick scan of this page it looks like you might be ok generally.. Since it mentions you need

acl ftp proto FTP
http_access allow ftp

But I see you made a spelling error or typo in your config file

http_access aloow ftp
share|improve this answer
Mein gott :) Thank you, barlop! But I think it's still not the solution, I'll try it tommorrow – gaffcz Sep 23 '11 at 17:59
Nothing, still doesn't work (squid restarted) :( – gaffcz Sep 24 '11 at 5:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.