Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to print out some colored text using ANSI escape sequences via the built-in echo command, it seems that the \e escape sequence in the string I provide is interpreted literally instead of as the "escape" it's supposed to represent. This only happens in Snow Leopard -- the examples below work as intended in Leopard.

Apparently echo does support the -e switch since it correctly interprets \n when using it:

~ $ 
~ $ echo "\n"
\n
~ $ echo -e "\n"


~ $

But when I try to use \e, I get this:

~ $ echo -e "\e[34mCOLORS"
\e[34mCOLORS
~ $

Like I said, in Leopard, the above would give me the string "COLORS" in color.

Does anyone know of a reason why this might be an intended change? How about a workaround for printing ANSI escape sequences from Bash scripts on Snow Leopard?

The Bash shell version on my Leopard machine is 3.2.17(1)-release and 3.2.48(1)-release on my Snow Leopard machine.

share|improve this question
    
The question contradicts the post. In the question you refer to /bin/echo, while in the post you use echo without path, which most probably is the builtin echo of your shell. –  0x89 Sep 3 '09 at 16:28
    
Of course -- thanks for noticing. I fixed the question to reflect this. –  hasseg Sep 5 '09 at 18:25

7 Answers 7

up vote 17 down vote accepted

I cannot tell you why it does not support that argument (you may have to ask the programmers about that). I only know that on my linux box, I get this:

$ /bin/echo --help
Usage: /bin/echo [SHORT-OPTION]... [STRING]...
  or:  /bin/echo LONG-OPTION
Echo the STRING(s) to standard output.

  -n             do not output the trailing newline
  -e             enable interpretation of backslash escapes
  -E             disable interpretation of backslash escapes (default)
      --help     display this help and exit
      --version  output version information and exit

If -e is in effect, the following sequences are recognized:
*emphasized text*
  \0NNN   the character whose ASCII code is NNN (octal)
  \\     backslash
  \a     alert (BEL)
  \b     backspace
  \c     produce no further output
  \f     form feed
  \n     new line
  \r     carriage return
  \t     horizontal tab
  \v     vertical tab

NOTE: your shell may have its own version of echo, which usually supersedes
the version described here.  Please refer to your shell's documentation
for details about the options it supports.

Report echo bugs to bug-coreutils@gnu.org
GNU coreutils home page: <http://www.gnu.org/software/coreutils/>
General help using GNU software: <http://www.gnu.org/gethelp/>
Report echo translation bugs to <http://translationproject.org/team/>
  • this does not mention \e escapes
  • it says that it is /bin/echo from gnu coreutils. As apple changes the source of their unix-system components from time to time (e.g. move from zsh to bash), check if there was a change for /bin/echo between Leopard and Snow Leopard. If it is gnu, you can ask the people at gnu.org why they choose not to include those sequences.

As for workarounds (thats more interesting): Not using /bin/echo, but bash's builtin echo works on linux boxes. If they changed to a bash without builtin echo (or something even more obscure), you could also try this not widely known feature of your shell (works at least in bash and zsh):

$ echo $'\e[34m''COLORS'

This is the matching part of bash's manpage:

   Words  of  the  form  $'string' are treated specially.  The word expands to string, with
   backslash-escaped characters replaced as specified by the ANSI  C  standard.   Backslash
   escape sequences, if present, are decoded as follows:
          \a     alert (bell)
          \b     backspace
          \e     an escape character
          \f     form feed
          \n     new line
          \r     carriage return
          \t     horizontal tab
          \v     vertical tab
          \\     backslash
          \'     single quote
          \nnn   the  eight-bit  character whose value is the octal value nnn (one to three
                 digits)
          \xHH   the eight-bit character whose value is the hexadecimal value  HH  (one  or
                 two hex digits)
          \cx    a control-x character

   The expanded result is single-quoted, as if the dollar sign had not been present.

   A  double-quoted string preceded by a dollar sign ($) will cause the string to be trans‐
   lated according to the current locale.  If the current locale is C or POSIX, the  dollar
   sign  is  ignored.  If the string is translated and replaced, the replacement is double-
   quoted.
share|improve this answer
2  
I wasn't aware of $'string' being escape sequence -enabled, thanks. –  hasseg Sep 5 '09 at 18:20

Try \x1B instead of \e.

share|improve this answer
2  
\x1B instead of \e does work, thanks. –  hasseg Sep 5 '09 at 18:19
2  
Just for reference, 1B is the hex value of the Escape character‌​. –  TachyonVortex Sep 21 '13 at 16:25

Does \033 still work? If not, you can hopefully press Ctrl+V followed by the Escape key (if a mac has those keys) to create a real control character inside the command line (which does not work that well in scripts of course, depending on the editor)

share|improve this answer
2  
\033 instead of \e does work, thanks. –  hasseg Sep 5 '09 at 18:18
1  
Just for reference, 33 is the octal value of the Escape character‌​. –  TachyonVortex Sep 21 '13 at 16:25

One other way of printing ANSI escape sequences in the shell is by using /usr/bin/printf.

share|improve this answer
2  
printf is the portable way of displaying things in shell. There are too many flavours of echo... –  mouviciel Sep 5 '09 at 19:56

They might try to conform to POSIX: http://www.opengroup.org/onlinepubs/9699919799/

Part OPTIONS states among other things:

Implementations shall not support any options.
share|improve this answer
    
Here is the direct link to the material I think you intended: opengroup.org/onlinepubs/9699919799/utilities/echo.html –  Dennis Williamson Nov 1 '09 at 2:21

FYI, We're just about to add \e support to /bin/echo and /usr/bin/printf in coreutils. Note the C standards do not specify \e, but gcc, perl, bash, ksh and tcsh support it

share|improve this answer

You might check if ,,escape non-ascii characters'' have been un-checked in the view options menu of the terminal.app.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.