Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I compile MacVim from source, I use a bunch of flags for configure:

./configure --enable-features=huge ...(enable python,ruby,perl, and c interpreters)... --enable-gui=macvim

But when I run vim, it doesn't have this feature enabled --remote-tab-silent, which I've been able to use in the past.

It also doesn't recognize the keywords undofile, undodir, or relativenumber. All of these worked when I used macports to install. So obviously, there's some features missing from my build, but I have no idea where to look to set the right configure flags.

Additionally, the only reason I am building from scratch is that the Command-T plugin requires the ruby interpreter, which macports doesn't compile by default. So if you have any suggestions how to get around that more easily than building from scratch, that would work as well.

Any idea what I should do to research this? Solutions? I'm very lost.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I believe it should be --with-features=huge and --enable-rubyinterp to get what you want. If undofile, undodir, and relativenumber are missing, make sure you're compiling version 7.3, since those were added in that version.

Under MacPorts, try sudo port install macvim +huge +ruby.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.