Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is a file in a folder. The filename is:

hello world -20110519.rmvb

and I tried to use the keyword 20110519 but no result is found. I think in 1980, computer was in really basic stage, and it is now 30 years later, and Windows 7 still cannot do something simple like this correctly, I am fairly disappointed. Why is the search not successful and what channel can this be sent to the Windows 7 team so that this bug can be fixed?

Update: if the file was hello world -20110519.txt, then the search will find the file. So the file extension matters? This must be the peak of civilization such things can happen.

share|improve this question
first 3 times I really Needed the w7 search, 2 of those it did not find files that I had with odd extentions. I of course tried some of the options to change it LOLOLOL. In folder options , there are a few things to change the search, good luck. it did not help me because i had already changed them. Organise - Folder and Search Options - Search Tab. – Psycogeek Sep 24 '11 at 3:48
Check out:… – Lance Roberts Sep 24 '11 at 6:00

I can't reproduce this, which leads me to suspect it's an issue with your file and not a general Windows Search issue. I have problems like this from time to time where certain files won't properly appear during a filename search.

Windows Search has gotten many facelifts over the years and it's still not great.

I'd suggest doing the following to narrow down what the cause is:

  1. Move that file to another directory and try the search again
  2. Rename it to something else and see if you can find it in a search
  3. Create a new text file and name it the same as your .rmvb

Depending on what happens, you can tell if the file is somehow unsearchable (sounds like a bug or at best poor user education on Microsoft's part), Windows isn't returning any .rmvb files in searches (must be a setting somewhere), or something else.

To be honest, if you need decent search on your local machine, Google Desktop is still the way to go. It's not as convenient as the search bar built into Windows Explorer, but it finds things very effectively.

share|improve this answer
Note that there is a space before the - and no space after it – 太極者無極而生 Sep 24 '11 at 7:51
Yes, I entered it with the space. It had no bearing on the search working or not. Whatever the issue with your search it, it's not related to a "magic" filename. What happens if you rename the file to test.rmvb? If it shows up in search I'd be baffled. – Stefan Mohr Sep 25 '11 at 8:39

I would check my regional setting and make sure Windows doesn't think 20110519 is a date.

Because in some parts of the world, like China, that is a valid date (Year, Month Date).

Try typing name:20110519 into the search box.


Made a file

enter image description here

Now with Search.

Maybe check that partial matches is checked under the Tools menu in file explorer?

enter image description here

Now with a weird extension. . .

enter image description here

share|improve this answer
wow, the computer nowadays is so smart that you have to do a "time / region" management before you do a search huh? – 太極者無極而生 Sep 24 '11 at 2:57
I can't fault Windows for guessing that is a date. I do fault Windows for not showing other matches when it was an implicit date query. – surfasb Sep 24 '11 at 2:59
Try it yourself -- for the file hello world -123456.rmvb -- Windows 7 again cannot find the file using the keyword 123456. Are you saying Windows 7 is so smart to try to interpret 123456 as a date? Then rename it to 12345 and it won't work again. And 12345 is a date? – 太極者無極而生 Sep 24 '11 at 3:04
I tried it and it worked. – surfasb Sep 24 '11 at 4:34

Where is the file located? Are you searching indexed folders? If the folder that the file resides is not indexed by search, typing it in the search box will not yield any results. Try telling it to search your entire computer.

My favorite way of brute forcing a search in Windows is using the command prompt. Run cmd.exe and then go to the root directory by typing cd \. Then type dir/s *20110519*.* and hit enter. It should find the file. If it doesn't, then it doesn't exist.


I just tried this myself by placing a file named hello world -20110519.rmvb in C:\test and then did a search and it came up. So I am not sure what's going on, in your case. If you did this and you aren't seeing the same thing, then I don't know, sorry. Screenshot below: enter image description here

share|improve this answer
try it in c:\try or something... as I said, if the filename has the extension .txt then it will be found. If the extension is .rmvb then it won't be found. Then would indexed or non-indexed matter? – 太極者無極而生 Sep 24 '11 at 3:13
You have to do it from the root directory (c:`). If you search from C:\try`, unless it's under that directory, it will not find it. dir/s will go through all folders and subfolders in that directory. Searching using this method will ignore indexed settings. Did you follow my instructions exactly? – Ben Richards Sep 24 '11 at 5:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .