Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a font and when I open it with Character Map, I see that there is a letter which is in the Delete Key! Here is a picture showing "U+007F: Delete":


Click to enlarge

So how can I display this letter?

share|improve this question
    
Which Windows version are you using? –  Jonas Heidelberg Sep 24 '11 at 9:08
    
Windows 7 .. why? –  Omar Sep 24 '11 at 9:34
    
Maybe you could add a windows-7 tag to your post... –  Jonas Heidelberg Sep 24 '11 at 9:42

1 Answer 1

up vote 2 down vote accepted

Last update+1: After Arjan's comment I've finally found a way; two in fact:

First working option

  • In Notepad or MS Word  (tested with Word 97 (sic!) and Win XP's notepad) type Alt 0127 which should just display as an empty box. Change the font to your font "QCF_BSML" and you should see the correct symbol:

screenshot of MS Word 97 showing U+007F character from QCF_BSML font

Second working option

Using Arjan's JSbin example, you can make the character visible and then copy it to whereever you need it. Note that Windows Wordpad (in Win XP) does not know how to deal with this character, in contrast to Notepad and MS Word.

screenshot of jsbin.com/ufehef/5

Old unsuccessful answers

For further reference, all the ways this question can't be answered:

First try (FAIL)

Clicking the Select button and then Copy does not work to put this character into the clipboard.

2nd try (FAIL)

According to the Unicode Character List Delete can just be produced using Alt 0127, but that does not work for this character.

3rd try (FAIL)

I have successfully created a binary file containing only the byte 0x7F using the hex editor frhed. I could then open this file with WordPad (in Windows XP) and copy the character into a UTF-16 document, where it had the correct code (0x007F). However, when I try to change the font to QCF_BSML, it still displays just as a box, and not as the symbol visible in charmap (see screenshot in the question).

4th try (FAIL)

The insert special character dialog in "MS Word" silently skips this character.

5th try (FAIL)

... using HTML in SuperUser:  (see source) doesn't work, but this is because SuperUser blocks the font tag. See above for how this works outside SuperUser.

share|improve this answer
    
On the other letters this worked, but only in this letter, after clicking the SELECT button, the COPY button remains disabled.. –  Omar Sep 24 '11 at 8:58
    
Thanks anyway for your time Jonas –  Omar Sep 24 '11 at 9:57
    
Nice. I am not on Windows, but curious: how does Windows show 0x7F for other fonts? Isn't that character in the question's screen capture just the word "delete", @Omar? –  Arjan Sep 24 '11 at 10:24
1  
Maybe HTML does work? Surely Super User does not allow that <font> tag and silently ignores it, so SU cannot be used to test it. And I don't have the font installed. But maybe this JSBin example shows it after all? (I guess it shouldn't, as it feels like an erroneous font, but please check, @Omar.) –  Arjan Sep 24 '11 at 10:38
    
@Arjan: I had the same thought, so I've tried with the font Omar uses offline on my PC. It didn't work, but now after a reboot the problem is solved. Maybe just Opera needed a restart to re-read the font list... silly me. I'll update the answer... –  Jonas Heidelberg Sep 24 '11 at 10:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.