Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get Windows to preserve the aspect ratio when playing games at low resolutions. I have an ATI Radeon HD 4350 graphics card.

Here are my software specs:

software specs

This is the place in the Catalyst Control Center where you would normally set image scaling options, but the "Maintain aspect ratio" option can't be changed because it's grayed out:

panel properties

Any ideas on fixing this? I found this thread, but the information appears to be out-of-date.

share|improve this question
add comment

2 Answers

I don't know if this is specific to so-called 'HD' monitors (monitors with native resolutions that are equivalent to things like 1080p) or maybe its the latest drivers but there were a few catches for me using these instructions.

  1. You may need to try a few different resolutions before you find one that allows you to change the image scaling settings.
  2. When going back to native resolution (in my case, HDTV 1080p) the normal grayed out 'scale to panel size' may show as selected once again, however it will behave as expected if you selected 'maintain aspect ratio' and applied before going back to native resolution per instructions above.

I had this issue with 'To the Moon' on Steam, before it was flattened to fit, after it is correct with black spaces on the side even though the grayed-out area still seems to show 'scale to panel size'.

share|improve this answer
add comment
up vote 1 down vote accepted

I managed to figure it out on my own:

  1. Change the resolution to something non-native for the monitor. That setting is under Desktop Management --> Desktop Properties.

  2. Go to My Digital Flat-Panels --> Properties (Digital Flat-Panel) --> Image Scaling. The options will no longer be grayed out.

  3. Change "Scale image to full panel size" to "Maintain aspect ratio"

  4. Change the resolution back to the native value. Even after doing this, the setting remains at "Maintain aspect ratio". Oddly enough, when I just checked the settings again now, it was back to "Scale image to full panel size", but when I tried running some software to test it, it was still working as expected.

Basically, there's a bug in the driver that prevents you from changing "Scale image to full panel size" to "Maintain aspect ratio" unless the driver is set to a non-native resolution.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.