Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Alright, here's the problem. My hard drive activity light on my custom built PC is blinking exactly once every second.

Microsoft has this to say on the issue: http://support.microsoft.com/kb/138598

There has been discussion on this issue several months ago: Why does my hard drive LED light blink every second?

The problem seems to stem from primarily Windows 7 polling the CD-ROM/DVD drive every second to see if something is inserted.

The Windows 7 users in the thread that was linked in the superuser question, https://social.technet.microsoft.com/Forums/fi-FI/w7itprohardware/thread/4f6f63b3-4b58-4154-9298-1566100f9d00, have confirmed that this IS a known issue with Windows 7. Some people point at the motherboard circuitry causing the CD-ROM and SATA activity to both be linked to that hard drive activity, but whatever the case, the temporary solution seems to be to disable the CD/DVD-ROM drive in Device Manager.

In fact, disabling the CD/DVD-ROM does stop the blinking, but of course this solution is counterproductive, because I shouldn't have to entirely disable a device to fix this problem.

I've done the following suggestions in that thread:

  • Change the autorun registry entry to 0
  • Completely disable autoplay in the autoplay control panel
  • Disable autoplay in the Local Group Policy Editor.

None of these stop the blinking from happening - apparently these solutions work for both XP and Vista, but it seems to be different in Windows 7.

So I'm wondering if anyone has found out how to completely disable the polling in Windows 7, or if this will just have to be an issue we will have to deal with. There's no option to disable the auto insert notification when you go to the device within device manager (there was in XP), so I got no idea where this option is hidden, or if there's a registry key entry I could change to stop the polling.

Anyone have any idea?

share|improve this question

5 Answers 5

This is much easier to do in Windows 7 than XP, no need to mess with the registry or group policy: Control Panel -> AutoPlay.

In Windows 7, it's just called AutoPlay instead of 'Auto Insert Notification'.

This lets you either globally disable autorun or choose default actions for different media.

share|improve this answer
    
If you read in the other comment threads - disabling AutoPlay doesn't help. I'll upvote you for trying to help though. :) –  White Phoenix Jan 2 '12 at 7:43

I do not have the same issue. But I can propose something you can try.

Have you tried disabling the built in DVD services? Namely Windows DVD Maker?

enter image description here

share|improve this answer
    
Didn't work. Was a good idea though. –  White Phoenix Jan 2 '12 at 7:43

The blinking hd-led is a Microsoft (Win7) problem.

I installed Win7 on a pc where WinXP was running before. In XP I disabled autorun in the registry and the hd-led stopped flashing.

In 7 there seems to be no way you can stop it, other than disable your DVD-ROM or disconnect the hd-led. Which are stupid suggestions. Disable Autoplay in Control Panel or select "Take no action" for all items, disabling it in the registry or using gpedit.mcs does not change a thing.

Microsoft is so short-sighted, that the solution they give themselves (http://support.microsoft.com/kb/138598) is no solution. There doesn't exist a "Settings" tab in the properties for the CD-ROM in the Device manager!

There is no virus, application or other cause, it's Microsofts "I know what is best for you, and I'll make you choke on it"!

share|improve this answer

Try disabling the "Shell Hardware Detection" service in services.msc or use the following from an administrative command prompt:

net stop "Shell Hardware Detection"
share|improve this answer

Check your antivirus date and do a scan. I had the same thing happen on a laptop and when the usb flash was plugged into a company pc I got a virus alert. Cleaned it and the once per second flashing stopped.

share|improve this answer
    
"We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed." –  gparyani Feb 5 '14 at 1:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.