Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm writing a little script to help deal with my music library. During development, I encountered some unexpected files in my readout in certain artist folders along the lines of AlbumArtSmall.jpg, Folder.jpg, etc...

I had my program output the exact path of these files. I opened up python and had os. Listdir the directory that they're in. Sure enough, they're listed.

However, Windows Explorer cannot see them. I have Show hidden files and folders checked and it correctly shows all sorts of other hidden files.

Most strangely, when in a command prompt at the offending directory, typing 'dir' DOES NOT list the files. However, typing 'ls' - which calls ls from the MinGW toolkit, does list them, and this is further supported by the python example above.

What in the world could cause these regular files to be hidden to Explorer and even the 'dir' command...?

share|improve this question
    
Try DIR /A see if that works –  barlop Sep 25 '11 at 6:18
2  
Just DIR, never shows hidden files or system files(which are like hidden). DIR /A shows them both/all. DIR /AH(or /A:H) just shows hidden. DIR /AS (or /A:S) just shows system. And the ATTRIB command would also list all the files and their attributes. So try ATTRIB Too. –  barlop Sep 25 '11 at 6:25
add comment

1 Answer 1

up vote 7 down vote accepted

Windows uses hidden meta files to make folder browsing faster. A classic example of this is the thumbs.db file that holds the thumbnails for the icons in the folder. If you want to see these files you will need to uncheck this box in folder options.

enter image description here

share|improve this answer
    
Your picture is extremely misleading. He wants that UNTICKED not ticked. Your text says it, but the picture doesn't. Extremely misleading –  barlop Sep 25 '11 at 6:23
    
Yeah, I've always thought the "Set to False" checkboxes were retarded. –  surfasb Sep 25 '11 at 6:43
    
Thanks. Don't know how these files got the "S" attribute, but I dealt with it. –  Chase Meadors Sep 25 '11 at 6:46
    
Image changed.. –  Moab Sep 25 '11 at 17:07
    
@Moab I thought the line "If you want to see these files you will need to uncheck this box in folder options." Explained the picture well enough. –  Scott Chamberlain Sep 26 '11 at 13:50
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.