Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't access http://developers.facebook.com on OS X Lion 10.7.1 in any way.

Safari:

Safari can't open the page because the server unexpectedly dropped the connection

Chrome:

Error 101 (net::ERR_CONNECTION_RESET): The connection was reset

Firefox:

The connection was reset. The connection to the server was reset while the page was loading.

The problem might have been caused by DNS/cache and so on, so I tried the following but to no avail:

  1. Deleted cache/DNS
  2. Created a dummy user account on my Mac
  3. Reinstalled the OS (through the Internet and all my settings remain intact)

Do you have any suggestions other than a fresh reinstallation of my Mac?

share|improve this question

migrated from stackoverflow.com Sep 25 '11 at 6:52

This question came from our site for professional and enthusiast programmers.

Try checking your proxy settings from your Network preferences. Or from Safari's Advanced preferences. I had similar issues and could not connect to Facebook or Yahoo, but everything else was fine. Clearing cache, history or reboot did not worked. I changed proxy settings until I had access and then changed back to original settings. It's working now.

share|improve this answer

Have you tried Renewing DHCP Lease?

System Preferences > Network > Your Connection > Advanced... > TCP/IP > Renew DHCP Lease

Have you also tried loading the link in Safari?

Also, if you have a wireless router, try rebooting it.

A while back I had some similar issues where some sites would just not load, similar "Connection" errors, and I ended up buying a new router.

share|improve this answer
    
thanks for the tip. I tried that renewing DHCP lease to no avail either. Also, the problem persists regardless of where i connect to the internet: at school, at home... My friend who has an exact Mac (Lion) can access the site without problems. It seems clear to me that the problem is on my machine itself, not the network. I just don't know how to fix this... – huy.gamedev Sep 27 '11 at 12:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .