Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I tried to connect my USB keyboard to another PC without USB, I used a USB to PS/2 converter but accidentally used the green connector, which is meant for mouses. So, my keyboard stopped working.

Does the keyboard have an internal micro processor or other electronic stuff that can break?

My keyboard doesn't even work anymore on my main PC. When I plug it into USB, all LED light turn green...

share|improve this question

closed as not a real question by Nifle, Ƭᴇcʜιᴇ007, ChrisF, Tom Wijsman, Dennis Jul 11 '12 at 18:23

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

up vote 2 down vote accepted

Does the keyboard have an internal micro processor or other electronic stuff that can break?

The answer is definitely yes. As opposed to some old style keyboards used in old home/personal computers, which were a passive switch matrix polled and decoded by the CPU, the PC keyboard is an active device. BTW, this is why it was possible to reprogram and tweak the old keyboards while it is harder in the PC world.

Whether it should be damaged by connecting to a mouse port - I don't think it should be harmful, but defective hardware is a possibility.

share|improve this answer

PS/2 connectors are usually interchangeable, although adapters made by different manufacturers don't always work with all hardware. I haven't heard of one being responsible for shorting out hardware unless you were trying to plug/unplug while the PC was on.

Try rebooting your main PC. It's possible that there was a glitch with USB detection if you tried hot swapping it too quickly.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .