Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed lighttpd, tried to run it service lighttpd start and got error like the one i post below. Please dont give me that crap about needing root (because I am root) or about ports higher than 1024.

So heres the error:

Starting lighttpd: 2011-09-25 21:51:14: (network.c.345) can't bind to port: 5555 Permission denied

and this is how i succedded to run it

 [root@torrenti ~]# lighttpd -f /etc/lighttpd/lighttpd.conf
 [root@torrenti ~]# service lighttpd status lighttpd (pid  1990) is
 running... [root@torrenti ~]# service lighttpd restart Stopping
 lighttpd:                                         [  OK  ] Starting
 lighttpd: 2011-09-25 22:05:49: (network.c.345) can't bind to port:  81
 Permission denied

                                                       [FAILED]

but as you can see in the end of my SSH log, when I try to use

service lighttpd command

it says permission denied again. There is already nginx and bunch of stuff running on server, so it`s not servers problem.

share|improve this question
    
Please post the results of a netstat -ant. You may want to consider editing your question to remove the "giving crap" type comments to make people more inclined to provide assistance. –  Paul Sep 27 '11 at 7:02
    
You try to connect to bind to port 5555, then with the second command, you go for 81. And you did not paste the first commmand wich resulted in the first code block output. Version and OS would be nice to know too. –  drahnr Aug 30 '12 at 21:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.