Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 Windows 7 Laptops. One of them works fine, but the other as of a few days ago and for no apparent reason is no longer identifying any network I try to connect to. When I turn on the wireless adapter -- a built in Realtek RTL8187B Wireless 802.11 b/g 54Mbps USB 2.0 Network Adapter -- it gives me a list of available networks.

When I click on one of them is gives me the loading bar, which shortly disappears and if I click on the bars at the bottom right of my screen it says that I am connected, but it is Identifying and I have no Internet access. Then it stays the same for at least an hour, that is longest I have let it sit and it never changed. It did do the Identifying before, but it always identified it after not too long and then I could do whatever with it.

I have looked on many websites, including several threads on this one, and tried many solutions -- such as re-installing the Realtek driver and using the route DELETE command -- but it still will not work. By the way, in case I did not make it clear enough in the preceding, I am not a computer expert, so I would be much obliged if you would try to make your answers as dumbed-down as possible. Again I have Windows 7.

share|improve this question
    
Does the event log say something on this? If not, you might want to check ifpconfig /all if it has DHCP or Internet; then also look if data is sent as well as received in the connection's properties and if so do a low level packet trace with Wireshark. Good luck! If all else fails, you might want to try step 12 and 13 I posted here... –  Tom Wijsman Sep 25 '11 at 20:55
    
I did not see anything in the event log. I tried ifpconfig /all and I got the message: " 'ifpconfig' is not recognized as an internal or external command, operable program or batch file." I cannot connect to the internet, so I cannot download Wireshark unless I burn a disk from this computer and put it on the bad computer, but I will have to buy the disks first. I also tried the steps in the link you provided and some of them said they were successful but I needed to restart my computer, others said that they were not recognized and/or failed to execute. I still cannot access the Internet. –  S. E. Vidrio Sep 25 '11 at 22:27
    
Oh, my bad, I made a typo there. It's ipconfig /all without the f. Pay notice to the IP address you received there, if it starts with 169 then DHCP is not working properly. Try manually configuring a static IP in that case... See a detailed explanation. –  Tom Wijsman Sep 25 '11 at 22:29
1  
I set up the IP address and now instead of stopping at "Identifying" it connects, but it tells me that it is an unidentified network and I still cannot access the Internet. Also, when I bring up Internet Explorer on the bad computer I now get a message "Google Toolbar has stopped working", and if I close it, it just pops up again. Does that mean anything? –  S. E. Vidrio Sep 25 '11 at 23:01
1  
I typed in the command prompt: ping x (where x is the good computer's IP) and received the following message: "Reply from Y (Where Y is the bad computer's IP): Destination host unreachable." It repeats that 4 times and then gives statistics. –  S. E. Vidrio Sep 26 '11 at 1:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.