Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On my my Windows XP SP3 box, when running Windows normally, from the command prompt I type chkdsk C: /R (or, equivalently, in Windows Explorer, right-click on the C: drive->Properties->Tools->Check Now...), I get the normal ... the volume is in use ... Would you like to schedule this volume to be checked the next time the system restarts? (Y/N) message. I choose Y, then later I do Start->Turn Off Computer->Restart.

When I restart, during the boot process I see white letters on a blue background that say

Checking file system on C:
The type of the file system is NTFS.
Cannot open volume for direct access.
Windows has finished checking the disk.

Later it seems to boot normally into the graphical desktop.

My understanding is that message comes from chkdsk when some other program is using the hard drive, so chkdsk does nothing.

What should I do to get chkdsk to actually check the disk? (How is it even possible that some other program starts running before Windows finishes booting up into Safe Mode?)

share|improve this question

4 Answers 4

I had exactly the same problem yesterday. For me the following fixed it:

  • Boot from an XP installation cd
  • When asked whether to install or repair, choose repair
  • Once you're in the repair console, run chkdsk /f or chkdsk /r on the volume you need.

The drives may not be in the same order as they are when you boot your XP. If you need to chkdsk any drive other than c:\ that also appears to be locked during boot (for example, a temp or swap volume), check via the MAP command which letter it is mapped to, and perform your chkdsk again.

share|improve this answer

During pre-boot chkdsk no other user-mode processes should be running, just the kernel itself and the loaded drivers. It might be a driver installed by malware (or anti-malware) which prevents access.

share|improve this answer
1  
You are probably right. What should I do about it? –  David Cary Sep 26 '11 at 16:32

I'm not sure what program may be preventing you from chkdsk from running, but you may want to try running chkdsk from something like Bart PE. That should be able to check the disk without other programs running, and if the check runs clean, that should clear the dirty flag on the drive so it wouldn't want to chkdsk on each boot.

share|improve this answer

You might have PC Tools/Spyware Doctor preventing you to do a chkdsk. You may consider remove it and perform the chkdsk and then install it back again.

Hope it helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.