Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Ubuntu Server 11.04 64 bit VM running on VMware Player 3.1.4 that only shows a black screen. No matter what I try, the screen remains black. The VM has worked the first time.

When I reset the machine, it shows the VMware loader and a flickering _ for about a second. Then the screen turns black again.

VM settings:

Memory: 512MB
Processors: 1
HD: 20GB
CD: auto detect
Floppy: auto detect
Network adapter: NAT
USB controller: present
soundcard: auto detect
printer: present
display: auto detect

I just created a fresh VM and the same happens, so it seems that the problem is consistent.

share|improve this question
    
Is this a fresh installation? Has it worked before? What are your virtual machine settings? Is anything mounted in the virtual disk drive? It'll be good to have more details. –  Jin Sep 26 '11 at 9:15
    
I tried ubuntu desktop, that seems to work sofar? –  Roel Veldhuizen Sep 27 '11 at 13:11
    
I wonder if the video resolution selected by Ubuntu is too high for your VM so it's gone "out of range". You can try booting your VM and (I think) hold down the SHIFT key (or send the shift key somehow) to get to the GRUB menu to select a VGA option to boot to. You can then lower the Ubuntu install resolution. –  Big Chris Jun 29 at 0:14
    
Are you trying to install a 64 bit OS into a VM environment that will only allow 32 bit architecture? This can cause this type of behavior as well. –  Ben Plont Jun 29 at 0:20
    
What is your host environment architecture (IE windows 7 64 bit)/ make and model of the computer it's installed on? What is the VM architecture you installed (32 or 64 bit)? –  Ben Plont Jun 29 at 0:26

4 Answers 4

I doubt it might work. You may wish to have a look here:

http://www.vmware.com/support/player30/doc/releasenotes_player3.html

share|improve this answer

I've seen a similar behaviour when you suspend the host OS while running a VM and later awaken it. I know it sounds silly, but have you tried rebooting your PC?

share|improve this answer

This type of behavior can occur if you install a 64 bit OS VM into a host environment that can only support 32 bit architecture VMs. Double check you VM/host environments. You can test this by installing (known good) 32 bit version of the same distro.

share|improve this answer

Just corrected this problem with Debian 7.5 and enabling hardware acceleration in VMWare Player machine settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.