Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my Ubuntu 11.04 installation. I've installed Ubuntu 11.04 from Windows, it worked fine for days, but today it won't boot.

When I start the machine, GRUB loads. There is the Windows 7 loader, I select Ubuntu from there and after that, I should see the Ubuntu GRUB menu, where I'd select the mode to boot Ubuntu. However, I can't see that anymore. I directly get to a GRUB terminal.

Can anyone help me with this? How would I recover my data or reset the boot loader?

share|improve this question
    
did you image the drive? sounds like some goofiness with UUIDs or not finding /boot –  hbdgaf Sep 26 '11 at 10:56
    
if you're using legacy disk indexes instead of UUIDs it could also be that you added a HD –  hbdgaf Sep 26 '11 at 10:57
    
i didn't do anythin. ... –  Badea Sorin Sep 26 '11 at 12:07
    
i'm not so expert on ubuntu, but i thing there isn't any grub to be loaded. How can a recover that ? –  Badea Sorin Sep 26 '11 at 12:08
    
Something must have changed. Could you describe what your partitioning layout is and where grub should be installed? –  pjc50 Sep 26 '11 at 12:57
show 1 more comment

2 Answers

up vote 0 down vote accepted

Try reinstalling your grub2 to the partition with Ubuntu:

  • Use an Ubuntu Live CD to start a live session

  • Identify the partition where Ubuntu is:

    • Open gparted (Type gparted in the dash home)
    • Identify the location of the partition. It should be something like '/dev/sda3' or '/dev/sdb2' (in general, '/dev/sd?#' where '?' is a single character and '#' is a digit)
  • Open a terminal

  • Mount that partition (substitute 'sda3' with the partition name you found previously):

    sudo -i
    mkdir /media/ubuntu
    mount /dev/sda3/ /media/ubuntu
    
  • Reinstall grub in that partition (substitute 'sda3' with the partition name you found previously):

    grub-setup -d /media/ubuntu/boot/grub /dev/sda3
    
share|improve this answer
add comment

I had the same issue and i found a solution after searching for many hours and it worked for me. You need to recover your Ubuntu installation disks via a disk check(chkdsk) in windows.

Running chkdsk

Depending on the problem, Windows may have run an automatic chkdsk or you may need to run it manually. It's not always necessary, but it will never hurt, so the first thing is to run it.

  • Go to My Computer on XP or Computer on Vista/7,
  • Right click the drive you installed Ubuntu on e.g. right click on C:,
  • Select Properties, select the Tools tab, then under Error-checking click Check now.
  • Select to Automatically fix file system errors or Scan for and attempt recovery of bad sectors
  • When the drive you installed on is C: the computer will tell you it has to schedule the scan for the next time you start your computer. Reboot to complete.

Locate recovered files/directories

The first thing to do is to look for the \found.000 folder on the drive in question i.e. C:\found.0000. This is hidden by default and (on my Windows 7 install) I also had to tell Windows not to "Hide protected OS files" just to see it. You may also have to recover from an administrator command prompt on Windows 7 (see below).

Hit the START key, enter CMD, then look above and right click on CMD.exe and select "Run as Administrator".

C:\>cd \found.000
C:\found.000>dir
 Volume in drive C is OS
 Volume Serial Number is B4B7-99A8

 Directory of C:\found.000

19/07/2011  02:02 PM    15,000,000,000 file0000.chk
               1 File(s)              8 bytes
               0 Dir(s)  222,258,069,504 bytes free

So now you look for your root.disk (or other .disk files) and copy them back to the \ubuntu\disks folder. If the entire \ubuntu\disks folder is missing, you'll likely find a dir0000.chk directory and within that the root.disk, swap.disk and empty \boot\grub folders. Copy this back to \ubuntu renaming the directory todisks.

C:\found.000>move file0000.chk \ubuntu\disks\root.disk
        1 file(s) moved.

Or if the whole disks folder is recovered:

C:\found.000>move dir0000.chk \ubuntu\disks
        1 dir(s) moved.

If you're missing the root.disk but there is no file of that name, it may have been renamed chk0000.chk. Rename this to root.disk and copy back to \ubuntu\disks.

If the corruption was minor, then likely everything will work fine. If the corruption is major Windows may not even recover the root.disk at all.

I have written a full post on this topic in this blog post. http://chanakaudaya.wordpress.com/2012/04/08/104/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.