Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am currently living through router config hell. My main internet connection is in living room A. It is an PPPoE ethernet cable which goes into main WiFi router WR1 (IP 192.168.1.1). This device handles login to the provider, firewall and DHCP for wireless devices in room A.

However, as I had very bad reception in room B, I had to setup second WiFi router WR2 (IP 192.168.1.200) configured as bridge, connecting to WR1. I just wanted to boost the signal. So I set up WR2 WAN IP address 192.168.1.200, giving it default gateway 192.168.1.1 (not sure about this one, but I wanted router WR1 to be its gateway). In LAN setup I gave it address 192.168.1.200. As I understand, WAN should be interface to main router WR1 whereas LAN creates "network inside network".

My problem is, this setup does not work as expected. Internet speed of WR1 is stable and high, whereas WR2 gives only 1/6 of WR1's speed via WiFi and about 1/4 via ethernet cable between PC and WR2. Furthermore, if I enable DHCP on WR2, this does not work and router just does not respond. I suspect there is some kind of IP address conflict because I have setup it on the same subnet.

My questions:

a. Is it possible to have bridged routers which create one big network wich DHCP enabled on both on them? If not, how can I setup WR2 to enjoy DHCP as well? WR2 currently has DHCP disabled so devices connected to it have their addresses assigned by WR1. It is kinda crazy.

b. Speed on WR2 was quite good, but something happened 2 days ago and it is not interference. Speed on WR2 plummeted to values above. Restarting did not help.*

c. How the hell shall I setup the whole thing (WAN and LAN interfaces on WR2) to achieve "one big network" goal? Or should I setup different LAN network on WR2, like: 10.0.25.1 and enable DHCP? Is it even possible in bridge mode?*

share|improve this question

migrated from stackoverflow.com Sep 26 '11 at 11:09

This question came from our site for professional and enthusiast programmers.

    
Why not just use a switch instead of a router? You actually don't need to route anything, just repeat the signal. –  m0skit0 Sep 26 '11 at 11:27
1  
@m0skit0: because I have no swith at hand. But I do have router... Plus I hate cables so extending the network wirelessly seems more elegant to me. –  summer.breeze Sep 26 '11 at 11:35
    
Switches can be wireless as well ;) Maybe your router can be configured to run as a switch, check that. –  m0skit0 Sep 26 '11 at 12:07
    
@m0skit0: Yes, but different vendors have different naming conventions for them, so it is sometimes very difficult to distinguish between them. My WR2 has these operation modes: A)Bridge (currently on), B)Gateway, C)Wireless ISP. Any idea which of these is switch? And before giving me advice to check my manual: I did. And while it has really nice doodles, it offers no explanation whatsoever on these modes (except repeating their names). –  summer.breeze Sep 26 '11 at 12:21
    
I cannot know if you checked your manual (sadly most people don't). I guess "bridge" would be the correct setup. It should not need an IP, or use DHCP, since a bridge purpose AFAIK is to just forward packets on layer 2 level (thus no IP involved here). –  m0skit0 Sep 26 '11 at 12:32

2 Answers 2

up vote 0 down vote accepted

Why don't you set the IP for WR2 to 192.168.1.2 its gateway as 192.168.1.1 enable dhcp on WR2 but use range1 for WR1 and range2 for WR2

Range1 could be 192.168.1.100-199 Range2 could be 192.168.1.200-254

If you are having bad reception issues in room 2 when you use a laptop or pci card/usb dongle then why would it surprise you that your WR2 is giving bad reception to the connected devices.

Cable is the way to go my friend. or failing that get power over ethernet.

Good Luck

share|improve this answer
    
Thank you for your advice Sam. I already had the WR1's range set up. I altered WR2's range and now all devices seem to be okay with it. I have already connected PC in room 2 with WR2 via ethernet cable and WR2's internet speed loss is about 10 % when compared to direct connection via the same ethernet cable to WR1 in the first room. So I think it is not so bad after all. –  summer.breeze Sep 29 '11 at 8:35

The second router needs to be on a different subnet. The default subnet mask is 255.255.255.0, so you need to assign the second router an IP address like 192.168.2.1.

share|improve this answer
    
Won;t DHCP have to be turned on for both routers though? –  TheLQ Sep 26 '11 at 18:00
    
@TheLQ, yes, it will. –  psusi Sep 26 '11 at 18:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.