Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a very weird hardware problem (I assume), my computer crashes sometimes when it is running. This is not the most weird part, when I boot the computer the GRUB 2.0 boot loader is displayed. After passing the boot loader and booting Windows 7 or Ubuntu 10.10 it crashes.

After several attempts it boots and works correctly (most of the time). So, my first solution was to create a delay in the GRUB boot loader because it seemed that it needed some time to "warm-up". Now, the problem is worse and I should add an addition delay to the GRUB boot loader.

  • The computer needs time to "warm-up"
  • If it is "warm" the computer crashes at the login screen of Ubuntu and Windows
  • Sometimes it crashes when I got it to run, but no logic found here
  • The computer never crashed at the GRUB bootloader
  • Memory tests didn't found any problems
  • The values of the power seem to be correct
  • Temperatures seems to be okey aswell.
  • I replaced the videocard

Any ideas?

share|improve this question

migrated from serverfault.com Sep 26 '11 at 15:11

This question came from our site for professional system and network administrators.

1  
Can you boot to a live CD? Have you pulled and re-seated all cards and memory? –  N4TKD Sep 26 '11 at 15:25
1  
Check the capacitors on the motherboard for swelling and bulging, it can also be a bad PSU. –  Moab Sep 26 '11 at 16:13
    
@JohnDR the live CD gives the same result, crash at the login screen. –  Roel Veldhuizen Sep 26 '11 at 16:58
    
@Moab, is there a way to log the PSU voltages? –  Roel Veldhuizen Sep 26 '11 at 16:58
    
Not that I know of, If I eliminate everything else, I replace the PSU. –  Moab Sep 26 '11 at 20:02

1 Answer 1

up vote 0 down vote accepted

Easiest way is what JohnDR says and try booting to a disk and see if that does something different, that will tell you hardware or software.

If it still fails, I would test the PSU first, as it is easiest to test.

If you have a second system and no boot disc. Pull the boot drive and put in a different machine. Even with no drivers for the different hardware Windows 7 should load. If it loads look at your Board/Processor/PSU. If it fails look at your software.

share|improve this answer
    
There are a number of software apps that will measure PSU voltages but they all run in Ubuntu or Windows, they are not boot programs. If you are going to test voltages get a Volt meter and have some fun. you should be able to find acceptable levels for your PSU on the web. –  MaskedPlant Sep 27 '11 at 15:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.