Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Running Ubuntu 9.04 fully patched on a custom machine. My typical setup is to assign static IP's to all my machines in the network (simplifies things with the other hardware). This morning, my machine was doing fine and I was able to get out and about just fine, Didn't make any configuration changes then. Tonight, after I got home from work, I can't resolve domain names on my box, but I can get directly to IP addresses. When I switch from using a static IP to DHCP, domain names resolve again and I can get out everywhere. Does anyone know what would have changed to stop resolving domains, and how I can fix it so I can use static again? Thanks.

share|improve this question
    
Ok, I'll have to try these as soon as I get home. –  Tom Sep 2 '09 at 15:18
    
I had the same problem although I didn't have a static-IP, the accepted solution (to use OpenDNS) worked for me. Thanks! –  Sverre Rabbelier Oct 13 '09 at 16:37
add comment

4 Answers 4

up vote 6 down vote accepted

System > Preferences > Network Connections > Edit > IPx4 Settings > DNS Servers. Whatever is placed there, it does not work, maybe because your ISP started blocking external DNS traffic. Try to put there addresses of the OpenDNS nameservers, that is "208.67.222.222, 208.67.220.220" without the quotes.

Does it help?

Another option is that the avahi daemon stopped working

share|improve this answer
    
The nameservers did it. Actually sped up my response time too. Thanks everyone. –  Tom Sep 3 '09 at 2:50
add comment

it seems to be a DNS problem,try OpenDNS

share|improve this answer
    
OpenDNS appears to be a proxy service. How would this solve a dns resolution issue? If it were my wife's windows box, I could do a tcp/ip reset with the netsh command, but I don't know of a linux version. –  Tom Sep 2 '09 at 4:25
1  
no,they provide DNS servers,you can use them instead of your router's –  Mahmoud Hossam Sep 2 '09 at 6:40
    
Bad idea, they are lying DNS resolvers, which modify the legitimate responses (for instance to direct you to advertisments). –  bortzmeyer Sep 3 '09 at 7:11
    
they do not do that,by the way advertisements haven't changed when i used their DNS's –  Mahmoud Hossam Sep 3 '09 at 15:59
add comment

When you say "all my machines in the network",
it seems you are referring to a local network at your home.
If that is correct interpretation, using static-IP addresses in this network
that resolve on hostname (any a common domain) require setting up the "/etc/hosts" file.

share|improve this answer
    
have two computers, printer, ps2, and cell phones all connecting to the internal network. everything with web browsers except my computer works just fine, not sure why ubuntu would need the hosts file set up since it's been running straight for a week without reboot and started sometime today during the day. –  Tom Sep 2 '09 at 4:27
add comment

Try using the Google-dns server.

IP's are 8.8.4.4 and 8.8.8.8, these work for me with arch Linux.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.