Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop is running Windows 7, and on our wireless network at work, I get a strange problem where every 5 minutes, DNS the network stops working. The admin here took a look at it, but concluded that it's a local problem, and since it's a personal laptop, there's nothing he can do (since I'm not about to let him re-image it :)

Anyway, I've found that if I do

ipconfig /release

followed by

ipconfig /renew

Then suddenly DNS the network works, and I can view the interwebs again. At least, until 5 minutes later when it stops working again.

On my wireless at home, this doesn't happen (i.e., DNS everything works fine forever).

Does anyone have any ideas about why it's doing this?

Windows 7 SP1 x64/Atheros AR5B97 Wireless Network Adapter

EDIT for Dan:

  1. I don't have access to a physical network jack for my laptop, but at home, plugging it in directly works fine. But, then again, so does the wireless.

  2. No, ipconfig /flushdns doesn't fix it.

  3. That's correct, all name resolution fails. I only have external names to test, as our wireless is on a completely isolated network from our wired LAN (the source of much frustration when someone asks how to access XYZ server from their laptop or whatever), but they fail:

    C:>ping Ping request could not find host Please check the name and try again.

Now, here's something I didn't realize before. If I add (for example) google's IP to my HOSTS file, then that still doesn't work:

C:\>ping mygoogle

Pinging mygoogle [] with 32 bytes of data:
Request timed out.
Request timed out.

Ping statistics for
    Packets: Sent = 2, Received = 0, Lost = 2 (100% loss),
  1. No, I cannot ping the DNS server either.
share|improve this question

migrated from Sep 27 '11 at 4:30

This question came from our site for system and network administrators.

Does the same thing occur if you connect over the wire, with wi-fi disabled?

Does ipconfig /flushdns fix the issue rather than /release & /renew

When you say DNS stops working, I presume you mean you don't get any resolutions if you ping a domain name. Does it fail with both internal names - (e.g. ping server1) and external names (E.g. ping

Have you tried disabling any firewall / Anti Virus software?

When it stops resolving, can you ping your listed DNS servers?

share|improve this answer
I've updated my question with answers to your questions. Interestingly, it seems that I am losing ALL internet connectivity... This so annoying :( – Mike Caron Sep 26 '11 at 15:03
If you can ping your default gateway but not beyond, then I think you need to bounce this back to your network team and demonstrate it to them. – Dan Sep 26 '11 at 15:13
That said, it doesn't really explain why an ipconfig /flush /renew fixes it. Unless your PC isn't USING the default gateway for some reason. Difficult to call without knowing more about the infrastructure. – Dan Sep 26 '11 at 15:21

Also verify you can get to any IP address at all, it may well be saying that it's unable to resolve a name but that would actually indicate it loses all internet connectivity. If you do an Ipconfig /all you will be given a list of information regarding your wireless adapter including a "default gateway". Once you're unable to resolve names try pinging this address (it should be in the format xx.xx.xx.xx). If you find you can't get to this then it means you have lost connectivity entirely. It is probably worth trying to manually update the drivers to see if this helps.

share|improve this answer
You may be on to something. I can still ping my gateway (, but no external ip addreses (, aka Google) – Mike Caron Sep 26 '11 at 15:07
Ok, that indicates a routing issue of some kind, could you please do "ipconfig /renew", then once connected run "route print" and save the output, then once you're seeing issues run "route print" again and check for issues. Post them here if you like and I'll see if I can point out anything obvious. – Alex Berry Sep 26 '11 at 16:57

If you set OpenDNS or Google DNS at your wireless network connection settings, does it still stops working after 5 minutes? Do you need to use your work's DNS Servers because of any internal servers you're accessing or is it OK to use 3rd party DNS servers?

Check here on how to setup OpenDNS on your Windows 7 laptop: link

Same instructions apply for Google DNS but use IPs and instead.

PS: I had a similar issue with my laptop (it had an Intel 4965AGN network adapter) when connecting to some Broadcom chipset based APs. Internet connection worked for a few minutes, then dropped. ipconfig /flushdns fixed the issue until a few minutes later. Turned out it was an incompatibility issue between the wireless adapter, and AP chipset. Is it possible to try if the same happens when you connect via ethernet cable to your work's network, or maybe can you get a WiFi USB adapter and see if the problem continues?

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .