Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Printing from a netbook to a shared printer attached to a desktop fails silently.

The desktop is running Windows 7 Professional (64-bit), and the netbook is running Windows 7 Home Premium (64-bit). Both are running Microsoft Security Essentials, and no other firewall that I know of. Both are attached to the same Homegroup -- I have verified that they are using the same Homegroup password. The printer is set to be shared. In the "Home network" configuration, password control for shared resources is explicitly disabled (which I think is redundant, given the two computers are part of the same Homegroup.)

If, on the netbook, I go through "My Computer" -> "Network", and double-click on the icon for the desktop, I get a prompt for the username and password of an account on the desktop, including a checkbox for storing the information. If I log in with a user account, then the netbook can access the printer attached to the desktop, as well as other shared resources. At this point, the "Homegroup" item appears in the tree view in Windows Explorer. The username and password don't seem to be cached between reboots.

Just to make it more puzzling, the desktop can see the shared resources on the netbook without any extra steps. The netbook does not have password control for shared resources disabled, and I have not had to "log in" from the desktop to the netbook. Apparently in that direction, the Homegroup settings work properly.

One other possible wrinkle is that the desktop is a dual-boot machine, and usually is on the LAN, with the same hostname and IP address, but running Ubuntu Linux rather than Windows 7; but the netbook only runs Windows 7.

In other words, I would expect the following, which are not the case:

  1. Entering the username and password should be unnecessary because both computers are part of the same Homegroup, and the printer is shared to the Homegroup.
  2. Entering the username and password should be unnecessary because both computers are part of the same LAN, and password protection for LAN-shared resources on the desktop is explicitly turned off.
  3. Entering the username and password should be unnecessary because the username and password have been entered before, and the checkbox to store the credentials is checked.
  4. If entering the username and password were necessary, the user should be prompted to do so when attempting to print.
share|improve this question
    
There's a comment in this discussion of a similar problem that suggests that the Homegroup feature depends upon DHCP-assigned IP addresses, and in my setup, the desktop has a manually-assigned IP, the netbook a DHCP-assigned IP address. Could that be the issue? –  bgvaughan Sep 27 '11 at 17:04

2 Answers 2

Please makes sure the user on both computers are the same, spelt the same way and have the same passwords. Also check the share permission on the printer to see if that particular user is attached to it so they can see that printer. Hope this helps.

share|improve this answer
    
The printer is shared without restrictions. Logging in with the remote user's name and password works just fine. The problem is that logging in should not be necessary at all. –  bgvaughan Sep 27 '11 at 16:34
    
Have you tried adding the users name to the share for the printer. Sometimes that everyone does be tricky. –  madbouy Sep 29 '11 at 19:16
    
I tried that. It didn't seem to make any difference, but then, it shouldn't -- Everyone already has printer permission. –  bgvaughan Oct 4 '11 at 17:55
up vote 0 down vote accepted

I figured out the problem. The last item under "Control Panel\Network and Internet\Network and Sharing Center\Advanced sharing settings" is "Homegroup connections", with two options:

  • Allow Windows to manage homegroup connections (recommended)
  • Use user accounts and passwords to connect to other computers.

The first seems like the obvious default, and that's how it's set for the (inactive) home network setting on my workstation at work; but for some reason, on the netbook, the second was set. This forces Windows to prompt the user for their account credentials on the remote computer, regardless of whether the remote computer requires them.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.