Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I’ve used esc to get out of vi’s insert mode for 40 years. I am not going to relearn that keystroke as ctl-esc, period.

Even if I were to do that, then I’d be typing ctl-esc on other platforms where it would not work because I have to type esc alone.

If there is a way to fix in in System Preferences, I cannot find it. If there is not, then it is completely 100% brain-dead wrong. I hope that’s not the case.

share|improve this question
2  
They're trying to force you to move to emacs. runs –  Ignacio Vazquez-Abrams Sep 27 '11 at 18:25
    
That would be nice, but I am also having trouble getting the X11 flavor of emacs to work. Yes, the character flavor works fine, but using the mouse to cut and paste is a requirement nowadays. That not withstanding, my virtual machines emulate systems too small for everything. "vi" is the only editor. Must...use...vi. :( - Bruce (emacs user since 1984) –  Bruce Sep 27 '11 at 18:39

3 Answers 3

The answer is: Speech Recognition takes the escape key by itself and does not make it clear that it has done so. I had apparently activated it without realizing it and it was non-obvious that it was the source of the problem. The solution is to either deactivate it or select a less obtrusive "mic on" key sequence.

share|improve this answer
    
Consider creating a question about why the hotkey was in use by Speech recognition when you didn't have a big-ass Speech item floating above all other windows with the label Esc in it and that flickered and changed color whenever you pressed the hotkey. And could you please remove the pointless rant in your question? –  Daniel Beck Sep 28 '11 at 17:48

This is basically due to the “Speakable Item Enable” as you set esc key to listen to your voice so please disable it for esc key proper functioning.

share|improve this answer

esc for exiting vi's insert mode works fine in both Terminal.app and iTerm2.app even in full-screen mode. Perhaps you have modified your profile or something remapping the esc key to something else.

share|improve this answer
    
If I did, it wasn't intentional. Also, I've meandered through every setting I can locate under System Preferences -> Keyboard -> Keyboard Shortcuts. I do not see a circumflex by itself. They all appear attached to another character, pointedly not including Control-escape (I guess that would be, "^Escape", but I don't see escape anywhere). I am using a terminal program named, "Terminal", by the way. –  Bruce Sep 27 '11 at 19:27
    
What DOES happen when you press esc in Terminal? –  Santi P. Sep 27 '11 at 19:42
    
No response at all. It is like not pressing anything. –  Bruce Sep 27 '11 at 19:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.