Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is it possible to run the ARM image of ubuntu-11.04-preinstalled-netbook-armel+omap4 in qemu? (Also used on the Pandaboard)

I have extracted the vmlinuz-2.6.38-1208-omap4 doing the following:

fdisk -u -l -C 512 ubuntu-11.04-preinstalled-netbook-armel+omap4.img

Outputs:

                                            Device Boot      Start         End      Blocks   Id  System
ubuntu-11.04-preinstalled-netbook-armel+omap4.img1   *          63      144584       72261    c  W95 FAT32 (LBA)
ubuntu-11.04-preinstalled-netbook-armel+omap4.img2          144585     5253254     2554335   83  Linux

Mount the rootfs and copy what I think is the vmlinuz file:

mkdir rootfs
sudo mount -o loop,offset=$((144585*512)) ubuntu-11.04-preinstalled-netbook-armel+omap4.img rootfs
sudo cp rootfs/boot/vmlinuz-2.6.38-1208-omap4 .

Next I tried to start Qemu:

qemu-system-arm -M versatilepb -m 1024 -cpu cortex-a9 -kernel ./vmlinuz-2.6.38-1208-omap4 -hda ubuntu-11.04-preinstalled-netbook-armel+omap4.img -append "root=/dev/sda2 mem=1024M devtmpfs.mount=0 rw"

I only get a blank screen. I've tried to change the RAM size (256,512,...) and the root fs (/dev/sda2). So far the only kernel setting I can get output from is the vmlinuz that came with one of the qemu (ARM) samples. I also tried u-boot.bin from the boot partition but this did not work either. I feel like I am completely missing something here.

Also I would prefer not to use rootstock if possible for the sake of learning.

share|improve this question

migrated from stackoverflow.com Sep 28 '11 at 3:32

This question came from our site for professional and enthusiast programmers.

2 Answers 2

Accoring to QEMU IRC, QEMU currently does NOT support OMAP4, i.e., pandaboard.

share|improve this answer
    
QEMU does support OMAP (ARMv7?) but I believe the answer is more along the lines that QEMU cannot emulate the hardware. I was looking for a way to disable the hardware part or emulate it... possibly write the emulated hardware piece? There doesn't seem to be any directions on how one goes about writing emulated hardware for QEMU. –  Nate Nov 27 '12 at 7:02

The image expects an OMAP4 processor, while you're giving it a generic Cortex-A9 from the Versatile-PB board. All the peripherals are likely different, so you don't even see error output on the serial. It seems currently there is no OMAP4 support in QEMU (you can check by passing -M ? and -cpu ? to QEMU), however there was a fork with OMAP3 support: http://code.google.com/p/qemu-omap3/. I don't expect it to work, but trying won't hurt, I guess.

share|improve this answer
    
This is a better answer. Thought QEMU does support ARMV7 Cortex-a9 (-cpu cortex-a9). –  Nate Nov 27 '12 at 7:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.