Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just installed CommandT for Vim, and it works very well, but there's an annoying bug/problem.

It seems that CommandT would change my working dir to the file I just opened. e.g. when I reach /foo/bar1/1.txt , :pwd tells me the working directory is /foo/bar1. Then I cannot navigate to /foo/bar2 unless manually use :cd.

Don't know if this is due to CommandT or some other plugin. Anyone got an idea?

share|improve this question

1 Answer 1

Include set noautochdir in your ~/.vimrc, and make sure that none of your other plugins has set autochdir enabled.

share|improve this answer
    
Thank u so much. Just learned about autochdir in vim. :) –  dofine Sep 28 '11 at 6:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.