Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new dell laptop, XPS L502X. I have tried to install Xubuntu 10.04 LTS 64Bit, which is the distro I love most. The problem is that it dosen't recognize my WireLess WiFi.

I have tried Ubuntu 11.04 and it works great and detects the wireless card. So I know there are drivers for my card for sure. But I don't like Ubuntu, I want Xubuntu and I want the LTS version 10.04.

How do I update the Wireless drivers card in Xubuntu to the latest one?

share|improve this question

2 Answers 2

Wireless drivers are often in the kernel, so your problem is likely due to kernel support for the driver being in the newer kernel and not the older one.

If there's a backported kernel (maybe in the backports repo) , its a simple matter of installing that. Else its a little trickier

I'd start by identifying the wireless adaptor with lshw, then either downloading and compiling the latest drivers yourself - or downloading and compiling the latest kernel yourself.

share|improve this answer
    
Hey @Journeyman, thanks for the answer. I used lshw. How do i know which one is the Wireless one. I found one that says *-network UNCLAIMED: Network Controller, Intel Corporation, pm msi pciexpress bus_master cap_list - so how do i compile driver for it? –  Aviv Sep 28 '11 at 9:15
    
hm, also try lspci. I need a line that looks something like 03:00.0 Network controller: Intel Corporation Device 008a (rev 34) - if so, you need the iwagn module, most likely –  Journeyman Geek Sep 28 '11 at 9:31
    
Here is the line from lspci: 03:00.0 Network controller: Intel Corporation Device 008a (rev 34). How do i update the iwagn module if i may ask? –  Aviv Sep 28 '11 at 9:43
    
intellinuxwireless.org/?p=iwlwifi you can get the drivers here –  Journeyman Geek Sep 28 '11 at 10:11
up vote 0 down vote accepted

Eventually i solved it, thanks to @Jorneyman Geek pointers.

Some information can be found here: http://ubuntuforums.org/showthread.php?t=1830848

But basically i used the backports repository for updating the kernel wireless stuff. The driver is iwlagn from Intel.

Here is the command i used:

   sudo apt-get install linux-backports-modules-compat-wireless-2.6.38-2.6.32-33-generic

Some commands for information:

 sudo lspci -nn (for network devices)
 sudo lshw (for list of devices and their drivers)
 sudo lsmod (devices and drivers)

Wireless control (the way i see them, might not be accurate:)

 iwconfig (configuring the wireless)
 sudo iwlist scan (scanning networks)
 rfkill list (viewing wireless devices connected)
 sudo modprobe -rf iwlagn (remove drivers)
 sudo modprobe -v iwlagn  (restore drivers)

I restarted, and it worked.

(edit) I have also added to /etc/apt/sources.list this line:

     deb http://archive.ubuntu.com/ubuntu lucid-backports main universe multiverse restricted
share|improve this answer
    
remember to select this answer as the correct one, once you can :) –  Journeyman Geek Sep 28 '11 at 10:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.