Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed fedora 14 and added two repositories from rpmforge and dag. When I use

 yum update

I get the following error after some processing.

Error: Package: libcurl-7.21.0-10.fc14.i686 (updates)
       Requires: libssh2(x86-32) >= 1.2.4
       Removing: libssh2-1.2.4-1.fc14.i686 (@fedora/$releasever)
           libssh2(x86-32) = 1.2.4-1.fc14
       Updated By: libssh2-1.2.7-1.el5.rf.i386 (rpmforge)
           Not found
Error: Package: libssh2-1.2.7-1.el5.rf.i386 (rpmforge)
       Requires: libcrypto.so.6

Also I get at last,

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I think it is a common problem. I tried with yum clean all but no use. Plese help me to resolve this.

share|improve this question

The RPMForge repository is intended to be used with Red Hat Enterprise Linux and its clones, not Fedora, and therefore they are incompatible and cause problems like what you're seeing. You'll need to remove it to get things working again.

Many of the packages in RPMForge are actually provided in the official Fedora repositories, which has a much broader package set than RHEL. The ones that aren't are available in the RPMFusion repository.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .