Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Chrome I have used a custom profile folder at C:\Pocket\Chrome. Whenever I open Chrome, I use the path C:\Users\Joseph\AppData\Local\Google\Chrome\Application\chrome.exe --user-data-dir=c:\pocket\chrome so everything is fine.

However the problem is that whenever I open a PDF file (Chrome is my default PDF viewer), it doesn't use the extension --user-data-dir=c:\pocket\chrome so it becomes the "default profile". (Now this is obvious since Chrome open PDF files in "tabs" and If I Ctrl + N it will show the homepage of the "default profile", verifying that it's not using my targeted profile)

I was wondering how do I fix this problem?

==
Windows Vista Home Premium SP 2

share|improve this question

1 Answer 1

I will keep the instructions below for reference.

Windows XP

My Windows is not set to English, so the interface controls can be a bit different.

  • Open Folder Options (should be in the Control Panel or in My Computer)
  • Select the File Types tab
  • Select the PDF extension and click Advanced
  • Select the Open action and click Edit...
  • Set the application field to C:\Users\Joseph\AppData\Local\Google\Chrome\Application\Chrome.exe --user-data-dir=C:\Pocket\Chrome "%1"

Windows 7

  • Open the Windows Registry Editor (Win+RRegEdit)
  • Go to HKEY_CLASSES_ROOT\.pdf. If the (Default) value has any data set, go to the key specified in there.
  • Change the data of the (Default) value in the shell\open\command subkey to C:\Users\Joseph\AppData\Local\Google\Chrome\Application\Chrome.exe --user-data-dir=C:\Pocket\Chrome "%1"
share|improve this answer
    
hmm I'm not sure what you mean by the File Types tab. But there isn't such a thing for me: screenshoot.me/TmEc4U –  Pacerier Sep 29 '11 at 23:51
    
@Pacerier: sorry, I was using Windows XP when I wrote those instructions. I've edited the post to add instructions for Windows 7. –  Aluísio A. S. G. Sep 30 '11 at 22:37
    
I'm using Vista I don't have the shell\open\command subkey take a look: screenshoot.me/KtUiLx –  Pacerier Oct 2 '11 at 1:38
    
@Pacerier: Yeah, I thought it could happen... try creating it and delete the PersistentHandler subkey. –  Aluísio A. S. G. Oct 2 '11 at 3:47
1  
Can you take a screenshot of chrome://version/? –  Aluísio A. S. G. Oct 3 '11 at 13:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.